cancel
Showing results for 
Search instead for 
Did you mean: 
Views: 1,715

Question

The R400/T400/T500/W500 with Win 7 is not prompting to install SP1. When checked in Systems at Control Panel. It does not show that Service Pack 1 is installed.

Answer

Ensure drivers have all been updated via Lenovo Support site

 

Graphic card driver must be version 8.792.5-110424b-119200C-Lenovo and above.

 

Version 8.792.5-110424b-119200C-Lenovo Switchable Graphics driver available below.

 

Driver

 

Text

 

 

 

Software name      ThinkPad Switchable Graphics Driver

Support models     ThinkPad R400
                   ThinkPad T400
                   ThinkPad T500
                   ThinkPad W500

Operating Systems  Microsoft Windows 7  32-bit, 64-bit

                   Refer to marketing materials to find out what computer models
                   support which Operating Systems.

Version            8.792.5-110424b-119200C-Lenovo

Support devices    ATI Mobility RADEON HD 3400 Series
                   ATI Mobility RADEON HD 3650
                   ATI Mobility FireGL V5700
                   INTEL GM45


<8.792.5-110424b-119200C-Lenovo> - (Fix) Fixed as issue where MSN Live Messenger 2011 did not respond when Switchable Graphics changed to Energy Saving mode with Windows 7 Service Pack 1 installed.

Please note that this is a temporary link and will be updated when the driver is posted on the Lenovo Support site.

 

  1. Download the graphic card driver first
  2. Uninstall the previous graphic card driver in "Programs and Features" at Control Panel
  3. Reboot laptop
  4. Install the downloaded graphic card driver
  5. Reboot laptop
  6. Go to Control Panel and use Windows Update
  7. Windows Update will prompt to install several security KB patches, install them
  8. Reboot laptop
  9. Go back to Windows Update and you will receive a prompt to install SP1.

 

 

 

 

Was this information helpful?

Contributors