Showing results for 
Search instead for 
Did you mean: 
Lenovo Staff
Views: 45,899


When I insert the SD Card in the SD Card slot on T420 I can see "Ricoh SD Disk Device" in Device Manager but there is a small icon with an arrow pointing downwards next to it. When I click on Properties the message "Device is disabled. (Code 22)" is there. When I click on Allow, nothing changes the state. The actual driver is from Microsoft from 21.6.2006 version 6.1.7600.16385.


I tried to download latest Lenovo drivers and installation seemed fine, but after restarting my system, the driver remains same like before. I even tried manual install but the Lenovo driver was rejected saying that it is not compatible. In BIOS the reader is allowed and I am using the latast available BIOS version. 


There appears to be a problem with the Media Card Reader.


Try the following steps: 


  1. Insert SD card in the reader
  2. Open Device Manager and locate:
  3. "Ricoh SD Disk Device" under "Disk Drives"
  4. "Ricoh PCIe SDXC/MMC Host Controller" under "IDE ATA/ATAPI Controllers"
  5. Unistall the drivers
  6. Remove SD card
  7. Install new drivers downloaded from the Lenovo Support site
  8. Restart computer
  9. Insert SD card



Was this information helpful?


Where are the drivers