cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
lovecraft
Ctrl-Alt-Del
Posts: 8
Registered: ‎01-05-2014
Location: Paris
Views: 21,808
Message 1 of 17

SSD Crucial m500 + T440s = 2100: Detection error on HDD0 (Main HDD)

Hi,

 

I used an SDD Crucial m500 480 Gb in my Thinkpad x201i for about a month.

It was configured in 'Self-Encrypting Drive' (SED) so my Thinkpad asked me a passphrase at boot.

It worked great, never got a problem with it.

 

Last week, I bought a t440s.

I decided to move my SSD into that t440s.

 

At first, I always got the same error message "2100: Detection error on HDD0 (Main HDD)" and wasn’t able to boot or install the OS.

I removed the SED passphrase (because I wasn’t sure if encryption was involved with the TPM chip or not) but that didn’t help.

 

I flashed the UEFI / bios to the latest version (2.17 at that time) without any more luck.

Then I updated the SSD Crucial m500 firmware to MU02 to MU03.

One of the fixes of that update is "Fix for potential Haswell compatibility issue (latest Intel platform)" which could only help.

And it helped : the drive was then recognized and I installed the Operating System after setting again a SED passphrase.

It worked great for several reboots but, this morning, a "hot reboot" (restart from the Operating System without power off), I’ve got the 2100 message error again...

I powered the system off, remove the power cord for several second then powered on and it worked but It keep me worried....

The problem is not permanent but It could be very bad to not be able to boot my laptop !

I thought I fixed the problem permanently with that firmware update but it seems not...

 

Do someone has any idea ?

Is that SSD a model to avoid installing in t440s ?

If so, are some SSD brand/model which work without any issue ?

Highlighted
Former Employee
Posts: 2,835
Registered: ‎03-20-2012
Location: Malaysia
Views: 21,717
Message 2 of 17

Re: T440s - 2100: Detection error on HDD0 (Main HDD)

Hi lovecraft,

thanks for posting and welcome to the community. Looking at your case could you possibly try the update below.

http://support.lenovo.com/en_MY/research/hints-or-tips/detail.page?DocID=HT076644

Hope this helps and please do post back your results.

Regards
lovecraft
Ctrl-Alt-Del
Posts: 8
Registered: ‎01-05-2014
Location: Paris
Views: 21,703
Message 3 of 17

Re: T440s - 2100: Detection error on HDD0 (Main HDD)

Thx.

Howver, that update is about an Intel 520 SSD which seems to have that same problem I have too.

I own a Crucial m500 and would like to have a solution for that one or, if it’s a known incompatibility that won’t be resolved, a list of SSD that I’m sure they are compatible would be nice (and, if Intel have the same problèm, I wouldn’t consider that one :-) ).

Former Employee
Posts: 2,835
Registered: ‎03-20-2012
Location: Malaysia
Views: 21,684
Message 4 of 17

Re: T440s - 2100: Detection error on HDD0 (Main HDD)

Hi lovecraft,

I think it the same with the crucial ssd, where by an updated crucial driver may be need. I'll need to check this and get back to you on this one. I'll post back as soon as i can get an update.

Regards
lovecraft
Ctrl-Alt-Del
Posts: 8
Registered: ‎01-05-2014
Location: Paris
Views: 21,670
Message 5 of 17

Re: T440s - 2100: Detection error on HDD0 (Main HDD)

Ok, thx. So I’ll wait for an update... I hope my PC won’t show me that message again. :-D
icewater
Blue Screen Again
Posts: 38
Registered: ‎01-04-2014
Location: US
Views: 21,656
Message 6 of 17

Re: T440s - 2100: Detection error on HDD0 (Main HDD)

I have just ordered a Crucial M500 480GB SSD (CT480M500SSD1).  Should I be concerned that this drive may not work with my T440s ??

 

(edit: btw I'm running Linux on this T440s)

 

 

Former Employee
Posts: 2,835
Registered: ‎03-20-2012
Location: Malaysia
Views: 21,633
Message 7 of 17

Re: T440s - 2100: Detection error on HDD0 (Main HDD)

Hi all,

thanks for posting. I did some checking on the issue and I believe the issue is primarily coming from the Crucial and specifically lenovo. Based from what I've found there is a firmware to address this issue. Please click on the link below.

http://www.crucial.com/support/firmware.aspx

do post back your results.

Regards
lovecraft
Ctrl-Alt-Del
Posts: 8
Registered: ‎01-05-2014
Location: Paris
Views: 21,619
Message 8 of 17

Re: T440s - 2100: Detection error on HDD0 (Main HDD)

In response to Icewater : The Crucial MU03 firmware update fixed most issue but not all. So it should mostly work for you, like for me.

lovecraft
Ctrl-Alt-Del
Posts: 8
Registered: ‎01-05-2014
Location: Paris
Views: 21,619
Message 9 of 17

Re: T440s - 2100: Detection error on HDD0 (Main HDD)

As I explained in my initial post, it’s what I did already.

And, indeed, the firmware update MU03 fixed most problem at boot but not all. I would like to be sure It won’t fail to detect my HDD some day.
Former Employee
Posts: 2,835
Registered: ‎03-20-2012
Location: Malaysia
Views: 21,589
Message 10 of 17

Re: T440s - 2100: Detection error on HDD0 (Main HDD)

Hi lovecraft,

thanks for posting back. My apologies for not rechecking your earlier post. Not to offend you you in any way, but have to tried to reseat the SSD to ensure that it is connected properly. I worked with a customer a while back which had boot issues and after chekcing turned out the SSD was not properly inserted. Maybe that would help checking.

In the mean time let check with our internal teams to get a shed abit more light on the matter.

REgards

Check out current deals!


Shop current deals

Top Kudoed Authors