English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

3 Posts

09-23-2019

FR

3 Signins

44 Page Views

  • Posts: 3
  • Registered: ‎09-23-2019
  • Location: FR
  • Views: 44
  • Message 1 of 2

Samsung 970 Evo Plus not detected on T580

2019-09-23, 21:17 PM

Hello,

I can't detect my Samsung 970 Evo plus NVME drive in the BIOS of my T580.

Even the Windows installer is clueless.

Here's what I tried :

 

- Factory NVME : Detected and working

- Bios update : Up to date.

- Plug the defective disk in an other computer : The disk works properly

- Change the SATA mode to AHCI : This option is unavailable in the BIOS.

- Disabling Secure boot : doesn't change anything

- Forcing boot mode on UEFI : doesn't change anything

 

Also, I need to install Linux in this PC.

At this stage don't have anything else to try, and I need your help guys.

 

Thanks.

Reply
Options

3 Posts

09-23-2019

FR

3 Signins

44 Page Views

  • Posts: 3
  • Registered: ‎09-23-2019
  • Location: FR
  • Views: 44
  • Message 2 of 2

Re: Samsung 970 Evo Plus not detected on T580

2019-09-24, 17:08 PM

Here's an update :

 

- Samsung said that the drive should be compatible.

- The drives that Crucial advertise as compatible with the T580 (SSD Crucial P1) use the same NVME revision as the Samsung 970 (1.3).

- Lenovo are ONLY advertising their own drives as compatible. Only issue is that most of them are in EndOfLife, pretty expensive and slow.

 

I will return my 970 Evo Plus to Amazon and try with a new one.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save