Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

21 Posts

12-14-2012

Germany

35 Signins

332 Page Views

  • Posts: 21
  • Registered: ‎12-14-2012
  • Location: Germany
  • Views: 332
  • Message 1 of 3

Sierra Wireless EM7345 4G LTE had event Fatal error: The miniport has detected an internal error.

2016-10-10, 5:01 AM

Hi ,

 

I have updated to the 1607 Anniversary Update in August and noticed that my WWAN Sierra Wireless EM7345 had problems starting up after reboot. Because of other problems with the 1607 I reverted back to 1511 and everything was alright again.

A week ago I upgraded again to 1607 and again, my WWAN sometimes cannot start when booting up. The error log shows Miniport Sierra Wireless EM7345 4G LTE, {b343453c-24e6-493d-ba47-33eaec4de5e3}, had event Fatal error: The miniport has detected an internal error (details see below). So this clearly has to do something with the 1607 update or the drivers for the WWAN. I am using the latest drivers from the Lenovo website and have also tried to update drivers in device manager. But no luck.

 

What helps to finally start the WWAN is either a reboot (the chances the WWAN is started properly are about fifty-fifty) or clicking WWAN off and on in flight mode options of Windows.

 

 

Maybe someone has an idea other than waiting for Microsoft to fix this stupid 1607?

 

Thanks and best regards,

Martin

 

 

Log Name:      System
Source:        Microsoft-Windows-NDIS
Date:          10.10.2016 06:37:19
Event ID:      10317
Task Category: PnP
Level:         Error
Keywords:      (16384),(16),(4),(2)
User:          SYSTEM
Computer:      Borkar
Description:
Miniport Sierra Wireless EM7345 4G LTE, {b343453c-24e6-493d-ba47-33eaec4de5e3}, had event Fatal error: The miniport has detected an internal error
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-NDIS" Guid="{CDEAD503-17F5-4A3E-B7AE-DF8CC2902EB9}" />
    <EventID>10317</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>2</Task>
    <Opcode>0</Opcode>
    <Keywords>0x2000000000004016</Keywords>
    <TimeCreated SystemTime="2016-10-10T04:37:19.775855300Z" />
    <EventRecordID>6333</EventRecordID>
    <Correlation ActivityID="{B343453C-24E6-493D-BA47-33EAEC4DE5E3}" />
    <Execution ProcessID="4" ThreadID="7360" />
    <Channel>System</Channel>
    <Computer>Borkar</Computer>
    <Security UserID="S-1-5-18" />
  </System>
  <EventData>
    <Data Name="IfGuid">{B343453C-24E6-493D-BA47-33EAEC4DE5E3}</Data>
    <Data Name="IfIndex">20</Data>
    <Data Name="IfLuid">68398969113280512</Data>
    <Data Name="AdapterName">Sierra Wireless EM7345 4G LTE</Data>
    <Data Name="MiniportEventEnum">71</Data>
  </EventData>
</Event>

Reply
Answer
Options

21 Posts

12-14-2012

Germany

35 Signins

332 Page Views

  • Posts: 21
  • Registered: ‎12-14-2012
  • Location: Germany
  • Views: 332

Re: Sierra Wireless EM7345 4G LTE had event Fatal error: The miniport has detected an internal error

2016-10-28, 23:29 PM

Aha, seems like this error is normal now with Anniversary Update,

https://support.microsoft.com/en-us/kb/2981681

 

 

Reply

Replies(2)
Answer
Options

21 Posts

12-14-2012

Germany

35 Signins

332 Page Views

  • Posts: 21
  • Registered: ‎12-14-2012
  • Location: Germany
  • Views: 332
  • Message 2 of 3

Re: Sierra Wireless EM7345 4G LTE had event Fatal error: The miniport has detected an internal error

2016-10-28, 23:29 PM

Aha, seems like this error is normal now with Anniversary Update,

https://support.microsoft.com/en-us/kb/2981681

 

 

0 person found this solution to be helpful.

This helped me too

Reply
Options

29 Posts

01-31-2018

Poland

48 Signins

1498 Page Views

  • Posts: 29
  • Registered: ‎01-31-2018
  • Location: Poland
  • Views: 1498
  • Message 3 of 3

Re: Sierra Wireless EM7345 4G LTE had event Fatal error: The miniport has detected an internal error

2018-02-06, 6:59 AM

It is restarting and not answering within 400ms window when resuming from sleep. Probably all users have this event logged (one time after resume), at least I have too - however my card is resuming without problem every time, just a few seconds delay.

So I am in this thread not because of problem but log content. I understand card is connecting to network and it takes a few seconds. However I think also phones are quicker to search and connect so question is if is it normal? Does someone have EM7455 resuming from sleep instantly (or nearly instantly)?

Of course it could also depend on network conditions, number of network providers and so on however for modern chipset shouln't it be nearly immediately?

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms