cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
bhamblin
Punch Card
Posts: 23
Registered: ‎10-27-2009
Location: Central US
Views: 5,611
Message 1 of 72

T400: Dithering(?) on gray colors when using ATI switchable graphics

Just noticed this afternoon that when my T400 is using the ATI high-performance graphics, all medium-to-dark grays (and presumably all colors in that lightness range) appear to be dithered (looks like a grainy, Photoshop texture applied).  When I switch to the Intel graphics, it goes away.

 

I've reset all the ATI drivers to default settings, reinstalled the drivers, made sure the display is a 32-bit color, 60 Hz refresh, etc., but nothing has fixed it.

 

I can't post any screenshots because the issue isn't picked up by them.

 

Any ideas?

LNahid2000
Punch Card
Posts: 9
Registered: ‎10-25-2009
Location: Waterloo, ON
Views: 5,563
Message 2 of 72

Re: T400: Dithering(?) on gray colors when using ATI switchable graphics

I'm glad to know I'm not alone!  I've had the same problem appear recently and it's driving me nuts.  I wonder what is causing it.

LNahid2000
Punch Card
Posts: 9
Registered: ‎10-25-2009
Location: Waterloo, ON
Views: 5,560
Message 3 of 72

Re: T400: Dithering(?) on gray colors when using ATI switchable graphics

After reading your post I realized that the only thing I did to my computer lately was update the BIOS, so I just downgraded the BIOS from 3.19/3.17 to 3.18/3.16 and the problem has disappeared! 

autostadt
Punch Card
Posts: 20
Registered: ‎01-04-2010
Location: Maryland
Views: 5,500
Message 4 of 72

Re: T400: Dithering(?) on gray colors when using ATI switchable graphics

Experienced the same problem after upgrading BIOS to 3.19. After reading this thread, I downgraded to 3.18 and the graininess is gone when using ATI.

Retired Guru
Posts: 372
Registered: ‎02-12-2009
Location: US
Views: 5,485
Message 5 of 72

Re: T400: Dithering(?) on gray colors when using ATI switchable graphics

If you would like to use the latest bios with the ATI drivers I would recommend loading CCC and setting the display saturation, brightness and contrast to suitable levels.  These settings will be stored for use whenever it switches to the ATI chip.

Thinkpad T500-2081 CTO | T9400 2.53GHz | 8 GB RAM | ATI HD3650 + Intel GM45 | 15.4" LED WXGA+ | Windows 10 | ATI Catalyst 13.1 (non-switchable)
Thinkpad 390x | PII 333 | 256mb ram | NeoMagic 256AV | SVGA LCD | OS/2 v4.52
wolruf
Punch Card
Posts: 9
Registered: ‎08-17-2010
Location: Paris
Views: 5,461
Message 6 of 72

Re: T400: Dithering(?) on gray colors when using ATI switchable graphics

Fantastic, I had this dithering issue too with a T400 since Bios 3.19. Just downgraded back to 3.18, all is fine. Big thanks! Lenovo should remove 3.19 bios asap.

bhamblin
Punch Card
Posts: 23
Registered: ‎10-27-2009
Location: Central US
Views: 5,432
Message 7 of 72

Re: T400: Dithering(?) on gray colors when using ATI switchable graphics

Figures it would be a BIOS upgrade!

 

Where did you get the older BIOS? I don't see it listed on the T400 download page.

wolruf
Punch Card
Posts: 9
Registered: ‎08-17-2010
Location: Paris
Views: 5,385
Message 8 of 72

Re: T400: Dithering(?) on gray colors when using ATI switchable graphics

EndLess
Paper Tape
Posts: 9
Registered: ‎12-23-2010
Views: 3,884
Message 9 of 72

Grain/Noise in Dark Photos from 3400 series driver update T400/T410

I have a T400.

 

I had my motherboard replaced because one of the USB ports was damaged and my computer was stuck on the ThinkVantage screen at startup.  That was fixed and I started playing a game that I've played occassionally over the last few months and got a blue screen crash after 30min of play.  An ati2dvag error.  So I read up on this error and realized that I needed to update my graphics card again. 

 

I uninstalled the driver and ati catalyst components and then rebooted so it reinstalled the default driver again.  Then I updated it with the latest driver update for the 3400 mobility radeon HD series that was released in September.  I actually downloaded it from this site.

 

Now some darker areas are a bit grainy that weren't before.  For example the dark banner at the top of the page is a little grainy.  The good thing is that I actually have more detail in photos, but I still have a major problem with darker areas.  It would be great if I could keep that detail without the grain but I doubt that it is possible and I'd rather lose the grain. 

 

 

I also booted up my machine in safe mode and the grain is still there even though everything is a bit blurrier.

EndLess
Paper Tape
Posts: 9
Registered: ‎12-23-2010
Views: 3,847
Message 10 of 72

Re: Grain/Noise in Dark Photos from 3400 series driver update T400/T410

Wish I could edit my post.  I just uninstalled the ati components again and uninstalled the graphics driver, and the problem is still there.

Check out current deals!


Shop current deals

Top Kudoed Authors