English Community

ThinkPad NotebooksThinkPad T400 / T500 and newer T series Laptops Knowledge Base

T400: How do I stop AMT from running?

Question

I'm running Windows 7 on my T400 2764CTO (BIOS 3.24). 

 

 The issue is when my PC is running it is listening on TCP port 16993 (AMT SOAP port) seemingly OOB of the OS's socket layer.  It also does this after post at Windows boot loader/menu before anything. AMT is a security risks. Is there any way to just turn it off?

 

For what its worth AMT is a competely separate computer within my thinkpad with its own separate processor and memory.  It responds to pings and accepts TCP/TLS sessions over the network by itself even while windows is NOT loaded or running.

 

There is no mention of anyhting AMT in the BIOS after having gone through the entire BIOS menu system. 

I've also tried CTRL-P on boot countlessly with no results and there are no bootup messages saying anything about AMT.

 

Unfortunatly turning off interface drivers such as "Intel Management Engine Interface" does nothing to stop AMT it just turns off the Interface between the separate computers.

Answer

A community user found out that distabling VT-d feature does the trick. You may want to try as below:

BIOS disable Config > CPU > Intel VT-d feature

 

A guess was that this feature is necessary to share network hardware with AMT.

Was this information helpful?

Yes No

Comments

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Delete