Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Paper Tape
Posts: 2
Registered: ‎11-30-2009
Location: Sweden
0 Kudos

T400, Performance issues with Intel VT

When I enable Intel VT in bios and later try to use Windows Virtual PC (or Hyper-V) the performance is really slow. If I disable Intel VT and use the old Virtual PC performance is better.


Anyone that have experienced the same issue? I have the latest bios installed and running Windows 7 (tried with both 32-bit and 64-bit).



Punch Card
Posts: 63
Registered: ‎08-11-2009
Location: UK
0 Kudos

Re: T400, Performance issues with Intel VT

[ Edited ]

I never had to complain about the performance. But I never tried to disable it in the bios. will try it later this week.

although I'm not sure if I would ever spot a difference, I can run 2 XP virtual machine simultaneously without any problem (the windows 7 host and the 2 XP VM are on a SSD disk though)


Paper Tape
Posts: 2
Registered: ‎11-30-2009
Location: Sweden
0 Kudos

Re: T400, Performance issues with Intel VT

ok, if you have had my issue, then you would have noticed. It's dead slow and the pointer lags when moved. 

Posts: 13
Registered: ‎12-03-2009
Location: USA

Re: T400, Performance issues with Intel VT, Virtual PC, Virtual XP

I realize the thread is old but maybe someone will find this and save themselves some time


The issue is caused by turning off some components used when switching between servicing calls for the host (the real machine) and the virtualized environment. Even the latest t400 BIOS has the "problem". At first I was really puzzled - I have a t9900 CPU and a SSD, nothing really makes the machine sweat too much. Yet you would click on a button in a program in the virtual machine and there would be no response or it will be SLOW. All at the same time CPU utilization stays at ~3%.


Try this with steps to fix the issue. No virtual machine should be running (may have to wait a few moments to free up the lock on the files)

1. Locate Options.xml in C:\Users\[YourUserName]\AppData\Local\Microsoft\Windows Virtual PC

1.5 Make a copy of the original just in case

2. Open the file in a text editor and find the section <virtual_machines>...</virtual_machines>

3. Replace the section with this


			<mm_timer_duration type="integer">10</mm_timer_duration>
		<enable_idle_thread type="boolean">true</enable_idle_thread>

 4. Save and start your virtual machine again.

5. Get yourself a cooler pad since each machine will run a CPU core at 100% utilization.


Alternatively, run the laptop in High Performance mode for power settings that turns off the timers that give us trouble.


Original source -