cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ipara
Punch Card
Posts: 14
Registered: ‎07-09-2010
Location: San Diego
Views: 3,031
Message 1 of 14

T400 Unknown Device in device manager

I just replaced the hard drive with a new one. I reinstalled all the software; however I can't seem to find the software needed to correct the error. I've downloaded the power manager and TRM software, but the problem remains. I'm running XP Pro 32 bit with SP3. The software listed states it's for SP2, not 3. Maybe that's the problem. I can't seem to find anything "new" in the company database. Besides this one error everything else is loaded and running fine. My computer is a 7417-TPU.

Guru
Posts: 906
Registered: ‎11-26-2008
Location: NO
Views: 3,000
Message 2 of 14

Re: T400 Unknown Device in device manager

Hi ipara,

It would be useful with some more info what kind of device this is. Device manager usually provide some more info with a short description that will tell what kind of device it is. Even better if you post the hardware ID for the device.


-gan

ipara
Punch Card
Posts: 14
Registered: ‎07-09-2010
Location: San Diego
Views: 2,966
Message 3 of 14

Re: T400 Unknown Device in device manager

Device Instance ID: ACPI\INTC0102\1

 

Hardware ID: INTC0102

 

"on Intel(R)ICH9M-E LPC Interface Controller"

lead_org Microsoft MVP Contributor
Microsoft MVP Contributor
Posts: 21,009
Registered: ‎12-19-2008
Location: Australia, Melbourne
Views: 2,959
Message 4 of 14

Re: T400 Unknown Device in device manager

you need to reinstall the Intel Chipset driver.

http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-70315


http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-72858 <----- this is all the relevant drivers for your laptop model.
Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
ipara
Punch Card
Posts: 14
Registered: ‎07-09-2010
Location: San Diego
Views: 2,940
Message 5 of 14

Re: T400 Unknown Device in device manager

Hi Lead_Org,

 

I reinstalled the chipset drivers, however It did not correct the "unknown device" problem. I did this several times and also rebooted the computer, however the problem remains.

 

Ipara

lead_org Microsoft MVP Contributor
Microsoft MVP Contributor
Posts: 21,009
Registered: ‎12-19-2008
Location: Australia, Melbourne
Views: 2,931
Message 6 of 14

Re: T400 Unknown Device in device manager

did you install the driver by going into the C:\SWTOOLS\DRIVERS folder?
Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
ipara
Punch Card
Posts: 14
Registered: ‎07-09-2010
Location: San Diego
Views: 2,927
Message 7 of 14

Re: T400 Unknown Device in device manager

The default path for the file is C:\DRIVERS\WIN\INTELINF, however I had the drivers download the files to C:\SWTOOLS\DRIVERS. In any case it still tells me I have a "unknown device".

lead_org Microsoft MVP Contributor
Microsoft MVP Contributor
Posts: 21,009
Registered: ‎12-19-2008
Location: Australia, Melbourne
Views: 2,920
Message 8 of 14

Re: T400 Unknown Device in device manager

http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-73684 <--- try this.

 

Also, did you install the Intel AMT drivers? and do you have intel turbo memory module installed?

Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
ipara
Punch Card
Posts: 14
Registered: ‎07-09-2010
Location: San Diego
Views: 2,896
Message 9 of 14

Re: T400 Unknown Device in device manager

First of all I reinstalled the chipset software via your link, didn't change a thing. I also reinstalled the AMT drivers, nothing changed; however when I tried to install the support over LAN I got a error message stating the hardware doesn't support it. I did install the disable intel turbo memory module software which could have worked, but it did nothing to get rid of the "unknown device". According to the disable memory module instructions XP doesn't support Intel's turbo memory module...

lead_org Microsoft MVP Contributor
Microsoft MVP Contributor
Posts: 21,009
Registered: ‎12-19-2008
Location: Australia, Melbourne
Views: 2,881
Message 10 of 14

Re: T400 Unknown Device in device manager

i will have a look at mine T400 tonight and see whether i can find the right hardware.
Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft

Check out current deals!


Shop current deals

Top Kudoed Authors