cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
banshee1
Paper Tape
Posts: 8
Registered: ‎07-14-2014
Location: ME
Views: 314
Message 1 of 7

T400 dead after replacing LCD

Pulled my T400 apart last night to replace the LCD and now it wont do anything.

 

After I plugged new screen in, I plugged the battery in to make sure everything worked before I buttoned it up and it wouldn't boot. The HDD and power on light come on for a couple seconds then they go right out. With just the battery I have to remove and reinstall the battery to try starting it again. With the battery out I have to unplug and plug the AC cord back in to be able to try again (the AC light goes out after it fails to start). With AC plugged in if I push and hold the power button it still fails to start but the AC light doesn't go out and I can try starting again without disconnecting the power source. I've tried the power button cycling trick and that didn't work. I've tried all the other suggestions I found by searching here, but none of the other topics are exactly the same as mine.

 

Anybody have any other suggestions?

 

I haven't tried remove the ram yet, but I removed the HDD and unit doesn't stay powered on long enough to get any beep codes.

I also haven't tried removing the cmos battery yet (doubt it will help but after working on pc's for 15yrs I've seen some pretty strange things work).

Wendel
802.11n
Posts: 497
Registered: ‎07-03-2009
Location: AD
Views: 296
Message 2 of 7

Re: T400 dead after replacing LCD

Where did you buy the LCD? Are you certain of its integrity?

 

If you think  the LCD is good, my suggestion assumes the process of replacing the LCD you inadvertently did something incorrectly or by accident. Therefore I'd slowly disassemble everything and then reassemble paying close attention to all plugs. A bent pin could be a problem. Make sure all plugs are secure and correctly positioned. They're small and sometimes not easy to align. Good luck.

banshee1
Paper Tape
Posts: 8
Registered: ‎07-14-2014
Location: ME
Views: 253
Message 3 of 7

Re: T400 dead after replacing LCD

I put the original screen back in thinking that if the hardware reported/detected a faulty screen it would automatically shut off. Didn't work either. All the connectors look fine as the keyboard plug contains the power button which turns the laptop on. I still haven't tried removing the ram to see if I can get any beep codes, but I have little hope. I've also tried not plugging the screen in and not plugging the mouse pad in and that didn't work either.

Not looking good.
Retired Support Specialist
Posts: 3,015
Registered: ‎03-14-2014
Location: Bangalore
Views: 226
Message 4 of 7

Re: T400 dead after replacing LCD

Hi Banshee1,

 

Did you check with connecting external display to verify it the system is working properly. Remove the connection from LCD and connect only external display such as Monitor or LCD TV and confirm.

 

Hope this helps.

 

Best regards,

Hemanth Kumar



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Rocko9999
Token Ring
Posts: 407
Registered: ‎02-13-2015
Location: USA
Views: 213
Message 5 of 7

Re: T400 dead after replacing LCD

You might have shorted the motherboard out. Did you resolve this?

banshee1
Paper Tape
Posts: 8
Registered: ‎07-14-2014
Location: ME
Views: 186
Message 6 of 7

Re: T400 dead after replacing LCD

I couldn't find anything so I took it to a local pc shop that I deal with thru work. They can't find anything ans came to the same conclusion I did. She's dead in the water. Guess I'm lookin for a replacement. Thinkin about taking a chance on a for parts unit on ebay. I think hdd and memory is fine so I can transfer those to new unit. Not having any luck finding one just like mine, but not gonna wait much more. 

 

Thanks for the suggestions though.

Rocko9999
Token Ring
Posts: 407
Registered: ‎02-13-2015
Location: USA
Views: 168
Message 7 of 7

Re: T400 dead after replacing LCD

Yeah, plenty of units at or around $100. I would just get a working unit and put your hard drive in and be done with it.

Check out current deals!


Shop current deals

Top Kudoed Authors