cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
jfd3220
Paper Tape
Posts: 8
Registered: ‎06-02-2010
Location: CA
Views: 27,249
Message 1 of 62

T410 Ultrabay HDD Question - SOLVED!

I recently bought an ultrabay adapter off ebay that was compatible with the T400/T400S.  The Lenovo part would be ThinkPad Serial Hard Drive Bay Adapter III, P/N 43N3412.  I took out the original 250GB HDD and put an Intel X25-V in the main HD bay.  Then I put the original drive in the Ultrabay Adapter.  When I power up the machine the Ultrabay drive spins up for a second and the light on the adapter comes on and then the drive turns off.  The Ultrabay drive is not found by the BIOS, I have 1.20-1.07 installed.  I called Lenovo tech support and was told that there is no Ultrabay adapter for the T410, and the website confirms this when I search for storage adapter accessories for it.  Is there some way to get a second HDD to work in the Ultrabay?

 

[EDIT]

The solution. Thanks to Dd16.

 

To enable the DVD automatic power off feature, open the Advanced view in Power Manager, go to the Power Plan tab and expand the System Settings dropdown. Now set Automatic Optical Drive Power Off to Enabled on AC and battery. (You'll be able to see and set this setting Automatic Optical Drive Power Off only if your DVD drive is inside of your ultrabay.) After being idle for 5 or 10 minutes your DVD drive will be powered off. Then this new icon (Other E: Powered Off) will appear in My Computer.    Make a shortcut of that icon on your desktop because after you remove your DVD drive this icon will disappear from My Computer. Remove the DVD drive, place your ultrabay hdd adapter, double click that shorcut which you placed on the desktop and it will power on your ultrabay. As I said in my previous post, after you restart Winodws you'll have to double click that shortcut again to power on the ultrabay.

 

You can just go to "Safely Remove Drive" to power it down when you're not using it.

lead_org Microsoft MVP Contributor
Microsoft MVP Contributor
Posts: 21,009
Registered: ‎12-19-2008
Location: Australia, Melbourne
Views: 27,208
Message 2 of 62

Re: T410 Ultrabay HDD Question

you got a knock off or the real one? 

Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
jfd3220
Paper Tape
Posts: 8
Registered: ‎06-02-2010
Location: CA
Views: 27,190
Message 3 of 62

Re: T410 Ultrabay HDD Question

It's a knock-off.  There are no discrete parts inside except for the status LED.  It just converts a regular SATA connector to an Ultrabay SATA connector through a PCB. 

lead_org Microsoft MVP Contributor
Microsoft MVP Contributor
Posts: 21,009
Registered: ‎12-19-2008
Location: Australia, Melbourne
Views: 27,178
Message 4 of 62

Re: T410 Ultrabay HDD Question

yes no SATA to PATA bridge, but the quality of soldering does vary. All it takes is a loose electrical connection to prevent the drive from working properly. 

Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
Retired Guru
Posts: 372
Registered: ‎02-12-2009
Location: US
Views: 27,157
Message 5 of 62

Re: T410 Ultrabay HDD Question

I would say this as well.. I have a good knock off ultrabay adapter for my T500 (looks like it came out of the same factory actually), however the quality control of these parts can be questionably.  Take a look at the connector and make sure there are no cracks in the plastic or contacts which aren't perfectly straight.  You may want to compare it to the optical drive to make sure the connectors are 100% in the same position.  Other then that you may have to get it replaced if you have that option.

Thinkpad T500-2081 CTO | T9400 2.53GHz | 8 GB RAM | ATI HD3650 + Intel GM45 | 15.4" LED WXGA+ | Windows 10 | ATI Catalyst 13.1 (non-switchable)
Thinkpad 390x | PII 333 | 256mb ram | NeoMagic 256AV | SVGA LCD | OS/2 v4.52
jfd3220
Paper Tape
Posts: 8
Registered: ‎06-02-2010
Location: CA
Views: 27,137
Message 6 of 62

Re: T410 Ultrabay HDD Question

I just noticed there is 1 capacitor across the power bus and 1 resistor for the LED.  I checked the continuity between the pins from the drive connector to the Lenovo connector and verified them all except the 3rd pin on the Lenovo SATA connector, which doesn't seem to be connected to anything. No cracked plastic.  I wish I could find a schematic, then I could just correct any possible error.  I am puzzled because the drive spins up for a second, so the power gets to the drive. Why wouldn't it work?  Is it the same part from the T400 to the T410?

jfd3220
Paper Tape
Posts: 8
Registered: ‎06-02-2010
Location: CA
Views: 27,129
Message 7 of 62

Re: T410 Ultrabay HDD Question

I found the pinout here: http://www.allpinouts.org/index.php/Serial_ATA_(SATA,_Serial_Advanced_Technology_Attachment)

 

Apparently the connector that is on the optical drive, and hence in the Ultrabay, is the SATA Slimline connector.  I don't know where the problem is. It may be one of the mate grounds is not right. 

bernZ
Fanfold Paper
Posts: 8
Registered: ‎07-09-2010
Location: Canada
Views: 26,672
Message 8 of 62

Re: T410 Ultrabay HDD Question

I recently bought one off ebay too. Similar to your situation, the activity LED flashes on for half a second briefly and then refuses to detect the presence of the hard drive.

 

Did you manage to solve the problem in any way? I'm also reading lots of little issues online regarding part number 43N3412 and compatibility with the t410/t510 laptops. Has anyone successfully used 43N3412 in a T410/T510?

 

 

Dd16
Token Ring
Posts: 11
Registered: ‎07-09-2010
Location: Lithuania
Views: 26,650
Message 9 of 62

Re: T410 Ultrabay HDD Question

 

A year ago I bought an ultrabay adapter (knock-off) off ebay for my T400. Recentrly I sold my T400 and got a T410. So I decided to try that ultrabay adapter on T410. In the begining it was behaving like jfd3220 described " When I power up the machine the Ultrabay drive spins up for a second and the light on the adapter comes on and then the drive turns off. The Ultrabay drive is not found by the BIOS".

 

Here is the trick how I made that adapter to work. May be it will help you too.

As you know in T410 optical drive (DVD) automatically powers off if it is not used for some time. When DVD drive powers off, a new icon appears in My Computer. It says something like "Other  E:    Powered Off".  If you double click that icon, DVD drive powers on again. What I did, I waited till my DVD drive powered off. After that icon came up(which says "Other E:   Powered off" ). I made a shortcut of that icon on my desktop.  Then I took out my DVD drive, put the ultrabay hdd adapter in, doubled clicked on that Power off icon on my desktop and that's it. This shortcut powers on the hdd adapter.  If you restart Windows you'll have to double click on that icon and that's it. Ultrabay HDD will work. At least it works for me. Let me know if that helped. My english is not good but I tried my best. Of course it doesn't help the BIOS to see the hd in the ultrabay. But the trick works in Windows.

 

 

I read on the net that original Lenovo Hard Drive Bay Adapter III, P/N 43N3412 works on T410 without any problem and tricks.

 

 

Darius

bernZ
Fanfold Paper
Posts: 8
Registered: ‎07-09-2010
Location: Canada
Views: 26,628
Message 10 of 62

Re: T410 Ultrabay HDD Question

Hi Darius,

 

Thanks for the info. Unfortunately for me my DVD stays powered on and I can't use your trick. Even if I could, it would be massively inconvenient to have to carry the dvd drive with me all the time just to wait for it to power off, then swap the hdd in.

 

Check out current deals!


Shop current deals

Top Kudoed Authors