cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
smok
Not applicable
Posts: 14
Registered: ‎09-24-2010
Location: Poland
Views: 1,179
Message 1 of 3

T410s: slow wireless

Hi,

 

I have just got a new T410s - and one thing spoiled my fun completely: my wifi connection is extremely slow (10 kB/s) which is not the case with another Thinkpad standing next to the T410s - so this is definitely not an access point problem. Signal quality is excellent, 11Mbit on both laptops. I'm just using the simplest possible test: download some MBs from Apache download and observe the transfer.

 

It did not work with the driver I had installed (13.2.1.5), so I installed the most recent drivers from Intel (13.3.0.24) - did not help. I googled a bit and I tried different suggestions, e.g. to set the card to maximum performance, uncheck any power-saving options - nothing. Checked the driver from Lenovo (13.02.0000) - nothing.

 

The card seems OK and this must be some problem with Power Managment since after several installs I managed to get it running OK with 13.2.1.5 - if miraculously started downloading data normally. But after my computer went to sleep last night and I woke it up this morning, everything is as it was before. Bad luck.

 

My OS is Windows 7 Professional 64-bit, the wireless card is Intel Centrino Ultimate-N 6300 AGN.

 

Please help!

 

Best,

Smok

Patryk
Not applicable
Posts: 39
Registered: ‎06-03-2010
Location: Poland
Views: 1,113
Message 2 of 3

Re: T410s: slow wireless

Change to energy star or maximum performance profile in Power manager and the WIFI performance will be ok.

You can manually modify power management settings for WIFI card in profile too (set to maximum transmit power).

smok
Not applicable
Posts: 14
Registered: ‎09-24-2010
Location: Poland
Views: 1,102
Message 3 of 3

Re: T410s: slow wireless

Thanks for your help, it's working now. It was not that simple, but it was related.

 

Here is the thread that helped:

http://forum.thinkpads.com/viewtopic.php?p=488867

 

with the options worth checking:

1. Device manager -> network adapters -> your wifi card -> Power Management -> uncheck "allow to turn off device to save power"
2. Windows power management -> advanced -> wifi -> power saving -> set to maximum performance
3. There is similar setting in Access Connections as well: advanced settings -> wireless -> power management -> set to max performance
4. Lenovo Power Manager -> Manage settings -> edit profile -> set wifi to max performance

I checked 1 and 3, cannot find 4 in my version of Power Manager (3.30) - the profile details do not have anything about wireless even in Advanced settings. Should they? Can you see that with your version? Which number is that?

 

It was 2 that helped - I thought Lenovo Power Manager overwrites it, so I had not check it before.

 

Thanks again,

Smok

Check out current deals!


Shop current deals

Top Kudoed Authors