English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

2 Posts

06-23-2016

RU

14 Signins

73 Page Views

  • Posts: 2
  • Registered: ‎06-23-2016
  • Location: RU
  • Views: 73
  • Message 1 of 6

T420 sound card randomly disappears

2016-08-03, 7:36 AM

Hello!
My T420 have latest BIOS, latest Windows 10 updates and drivers, Ubuntu 16.04 LTS kernel and updates. Randomly my sound output is disappeared :

  • Windows 10, there is a red cross on volume gauge, clicking on it calls standard wizard of resolving drivers problems, it's doing some magic and asks for reboot. After reboot all works fine, but after sleep, reboot or shutdown it occurs again.
  • in Ubuntu in sound manager sound output reverts into fictive output, no sound, no volume meter, in lspci device list there is no intel hda output device. After several reset, it dissappears and also all works fine but again, same as in windows it can occurs again.

Please help me, thanks in advance.

Reply
Options

1 Posts

04-16-2017

DE

1 Signins

9 Page Views

  • Posts: 1
  • Registered: ‎04-16-2017
  • Location: DE
  • Views: 9
  • Message 2 of 6

Re: T420 sound card randomly disappears

2017-04-16, 16:31 PM

Hello,

 

I have the exact same problem with my T420, dual booting Windows and GNU/Linux..

Have you ever found a fix to this?
If so, it would be great if you shared your solution.

Thanks in advance.

Reply
Options

10534 Posts

01-02-2010

US

39303 Signins

406737 Page Views

  • Posts: 10534
  • Registered: ‎01-02-2010
  • Location: US
  • Views: 406737
  • Message 3 of 6

Re: T420 sound card randomly disappears

2017-04-16, 18:11 PM

It is impossible to diagnose from far away, but I have seen a couple of machines in that series (420, 520) have sound chips (on the motherboard) die.


Rich


I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo.
Reply
Options

3 Posts

06-29-2011

Moscow

9 Signins

51 Page Views

  • Posts: 3
  • Registered: ‎06-29-2011
  • Location: Moscow
  • Views: 51
  • Message 4 of 6

Re: T420 sound card randomly disappears

2017-04-16, 19:25 PM

Hello.

I don't have a solution. You can try this: unplug your laptop from power adapter, unmount battery, press and hold on/off button for 5-10 sec. It works for me two or more months. I don't sure, but this problem may be caused by static electricity - there is no electrical grounding in my power socket.

Reply
Options

3 Posts

09-02-2017

GB

6 Signins

53 Page Views

  • Posts: 3
  • Registered: ‎09-02-2017
  • Location: GB
  • Views: 53
  • Message 5 of 6

Re: T420 sound card randomly disappears

2017-09-03, 10:40 AM

wrote:

You can try this: unplug your laptop from power adapter, unmount battery, press and hold on/off button for 5-10 sec. It works for me two or more months. 


Genius!  That brought my audio device back from the dead.  When you say for two or more months, do you mean it will eventually fail completely?

Reply
Options

3 Posts

06-29-2011

Moscow

9 Signins

51 Page Views

  • Posts: 3
  • Registered: ‎06-29-2011
  • Location: Moscow
  • Views: 51
  • Message 6 of 6

Re: T420 sound card randomly disappears

2017-09-03, 19:01 PM
Since april, after reset, my audio works fine.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save