cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
koman4all
Paper Tape
Posts: 4
Registered: ‎03-14-2014
Location: Phoenix AZ
Views: 2,085
Message 1 of 9

T420 wifi problems

Hi,

 

I am running into wifi disconnecting issue for my windows 8.1 Lenovo T420 laptop. My office laptop T430 (previously 420), both of those do not have any issues with wifi.

 

I have tried most of the solutions in the internet such as change the power management to maximum performance, update the drivers, change the dynamic DNS to static. nothing works. Can someone in this forum help me with the correct solution. Thanks.

 

Details about network adapter diagnosis:

Network adapter Wi-Fi driver information:

Description . . . . . . . . . . : Intel(R) Centrino(R) Advanced-N 6205
Manufacturer . . . . . . . . . : Intel Corporation
Provider . . . . . . . . . . . : Microsoft
Version . . . . . . . . . . . : 15.10.0.12
Inf File Name . . . . . . . . . : C:\WINDOWS\INF\netwew00.inf
Inf File Date . . . . . . . . . : Thursday, August 22, 2013 7:01:07 AM
Section Name . . . . . . . . . : Install_MPCIEX_Gui_6205_AGN_2x2_HMC_WIN8_64_MOW
Hardware ID . . . . . . . . . . : pci\ven_8086&dev_0085&subsys_13118086
Instance Status Flags . . . . . : 0x180200a
Device Manager Status Code . . : 0
IfType . . . . . . . . . . . . : 71
Physical Media Type . . . . . . : 9
Informational
Diagnostics Information (Wireless Connectivity)
Details about wireless connectivity diagnosis:

Information for connection being diagnosed
Interface GUID: fabd739e-8838-4497-afdb-63249f50bb49
Interface name: Intel(R) Centrino(R) Advanced-N 6205
Interface type: Native WiFi

Connection incident diagnosed
Auto Configuration ID: 1
Connection ID: 1

Connection status summary
Connection started at: 2014-04-07 22:18:49-519
Profile match: Success
Pre-Association: Success
Association: Success
Security and Authentication: Success

List of visible access point(s): 0 item(s) total, 0 item(s) displayed

Connection History

Information for Auto Configuration ID 1

List of visible networks: 1 item(s) total, 1 item(s) displayed
BSS Type PHY Security Signal(RSSI) Compatible SSID
------------------------------------------------------------------------------
Infra a Yes 100 Yes

 

Retired Support Specialist
Posts: 3,015
Registered: ‎03-14-2014
Location: Bangalore
Views: 2,064
Message 2 of 9

Re: T420 wifi problems

Hi Koman,

 

Welcome to Lenovo Community!

 

I’m sorry to hear that you are facing the issue with Wifi disconnecting frequently on ThinkPad T420.

 

Regarding the issue I am providing the link for that, please follow the steps from the link to resolve the issue.

 

Please click here to enter the link.

 

Hope this helps. Do post back if issue persists!

 

Best regards.

Hemanth Kumar



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

koman4all
Paper Tape
Posts: 4
Registered: ‎03-14-2014
Location: Phoenix AZ
Views: 2,047
Message 3 of 9

Re: T420 wifi problems

Hi Hemanth,

 

Issue still persist after changing the transmit power option as well as power management option.

 

Wifi disconnects every 2-3 minutes. Working with ethernet cable is just fine.

Retired Support Specialist
Posts: 3,015
Registered: ‎03-14-2014
Location: Bangalore
Views: 2,036
Message 4 of 9

Re: T420 wifi problems

Hi Koman,

 

Thank you for replying us back.

 

As per the drivers version which you have mentioned earlier was updated from Microsoft update, I suggest you to update the drivers from Lenovo drivers page. Sometimes Microsoft updated drivers will not be compatible, hence requesting you to update the driver from Lenovo drivers page.

 

Below is the link to enter the downloads page and install Wifi driver and check accordingly, please click on "Select Product" then in "QUICK PATH" enter the MTM no. select the exact model.

 

http://support.lenovo.com/en_US/downloads/default.page#

 

Hope this helps. Do post back if issue persists!

 

Best regards.

Hemanth Kumar



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

koman4all
Paper Tape
Posts: 4
Registered: ‎03-14-2014
Location: Phoenix AZ
Views: 2,000
Message 5 of 9

Re: T420 wifi problems

Hi Hemanth,

 

I have updated the latest driver, wifi disconnects every 15 mins or so, although not 2 mins as it used to be. 

Retired Support Specialist
Posts: 3,015
Registered: ‎03-14-2014
Location: Bangalore
Views: 1,987
Message 6 of 9

Re: T420 wifi problems

Hi Koman,

 

After updating the driver have you checked with changing the power option setting which I had given you earlier.

 

Please click here to enter the link.

 

Hope this helps! 

 

Best regards,

Hemanth Kumar



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

koman4all
Paper Tape
Posts: 4
Registered: ‎03-14-2014
Location: Phoenix AZ
Views: 1,969
Message 7 of 9

Re: T420 wifi problems

After updating the driver, I have checked the power option to find it is configured as you recommeded. Issue still persist 

Guru
Posts: 9,598
Registered: ‎12-26-2009
Location: CA
Views: 1,961
Message 8 of 9

Re: T420 wifi problems

Can you ping 8.8.8.8 when it drops out or does that also fail?

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Retired Support Specialist
Posts: 3,015
Registered: ‎03-14-2014
Location: Bangalore
Views: 1,946
Message 9 of 9

Re: T420 wifi problems

Hi Koman,

 

Thank you for replying back. Sorry for delay in reply.

 

Did you try to change the WiFi channel on your wireless router? Maybe there is some wireless interference which cause your wireless drops.

 

There are a lot of router with dropping WiFi problems especially with multiple devices attached and active.

Reboot your routers and check the configuration once, and also check with updating the routers firmware. If possible check with a different brand of router.

 

Hope this helps! 

 

Best regards,

Hemanth Kumar



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Check out current deals!


Shop current deals

Top Kudoed Authors