English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

4 Posts

05-06-2012

Australia

5 Signins

74 Page Views

  • Posts: 4
  • Registered: ‎05-06-2012
  • Location: Australia
  • Views: 74
  • Message 1 of 5

T420s ExpressCard Slot not working

2012-05-06, 2:55 AM

Hi everyone,

 

I just recently purchased a customized T420s with an Expresscard SD card reader. However it can not be discovered in Win 7 Pro. I pluged the same Expresscard slot SD card reader into my the other notebook, and it is working. I tried to re-install the operation system from the default recovery drive. The BIOS setting is untoughed. (Verion 1.31). Still it is not working(no tone when pluging or unpluging).

 

So this Expresscard slot on my T420s is not working at all. Is there any driver I need to install?

 

Many thanks!!!

 

0B06026 VBB INTEL CORE I7-2640M PROC    
       45M3090 VBB GENUWIN7PROFES.64    
       0A68625 SBB GW7P64 E    
       0A68976 SBB 14HD+LDBCKLTANTGLDSPMBBBRD    
       0B06390 SBB NVIN12PNS2OPG1GICI7-2640MP    
       45M4572 VBB 4GBPC3-10600DDR3 1333SODMM    
       45M4839 SBB KEYBOARDUS ENGLISH    
       0A68978 SBB FINGERPRINT READER    
       0A68993 SBB 720P HD CAM+INTGR MCRPH    
       0A68992 SBB IT160GB SLDSTDRV,SRATA    
       0A68985 SBB DVD RCRDBL8XMXDLLRULTRBSLM    
       0A68996 SBB EXCRSLOT+4IN1CRDRD+STCRDRD    
       0A68980 SBB 6 CELL LI-ION BATTERY    
       39T6442 SBB COUNTRY PACK NORTH AMERICA    
       0A68261 SBB BLUETOOTH 3.0    
       45M4804 SBB IN.CENT.ULTIMATE-N 6300    
       44C7950 SBB INT WRLSSWDAREANTWRK UPGR    
       0A69000 SBB LANGUAGE PACK US ENGLISH

 

Reply
Options

20986 Posts

12-20-2008

Australia, Melbourne

20622 Signins

444194 Page Views

  • Posts: 20986
  • Registered: ‎12-20-2008
  • Location: Australia, Melbourne
  • Views: 444194
  • Message 2 of 5

Re: T420s ExpressCard Slot not working

2012-05-06, 3:41 AM

you mean the 4 in 1 card reader doesn't work?

does it get detected under the hardware property?

It should be automatically detected when you plug and unplug it, well at least this is the case when i tested the T420s of mine friends' when i was showing them how use an eGPU solution.

Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
Reply
Options

4 Posts

05-06-2012

Australia

5 Signins

74 Page Views

  • Posts: 4
  • Registered: ‎05-06-2012
  • Location: Australia
  • Views: 74
  • Message 3 of 5

Re: T420s ExpressCard Slot not working

2012-05-06, 4:07 AM

Yes, the 4 in 1 card reader can not be detacted by Win 7 at all. It is working with my the other pc.

 

I will need this ExpressCard slot working for eGPU solution as well...

Reply
Options

2640 Posts

03-21-2012

Malaysia

2405 Signins

55976 Page Views

  • Posts: 2640
  • Registered: ‎03-21-2012
  • Location: Malaysia
  • Views: 55976
  • Message 4 of 5

Re: T420s ExpressCard Slot not working

2012-05-08, 9:26 AM

hi Kevindiao,

 

I'm not sure if this helps but it is worth checking out.

 

http://support.lenovo.com/en_US/research/hints-or-tips/detail.page?DocID=HT037677

 

In that site there are a list of newest drivers for the card reader. you mmght want to take look and see in loading the drivers might help in any way.

 

Do let me know how it goes,

 

Regards

Reply
Options

1 Posts

10-07-2016

CA

1 Signins

9 Page Views

  • Posts: 1
  • Registered: ‎10-07-2016
  • Location: CA
  • Views: 9
  • Message 5 of 5

Re: T420s ExpressCard Slot not working

2016-10-07, 15:57 PM

I followed this thread through and some wise person below mentioned going into the BIOS and turning off PCI power management.  This worked like a charm for me for ALL of my expressCard devices!  Please try to change the BIOS setting first - I think this solves a lot of issues.

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save