cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DIWilds
Paper Tape
Posts: 1
Registered: ‎05-16-2018
Location: US
Views: 188
Message 1 of 1

T420s Network Adapter Troubleshooting

The system:

T420s ThinkPad (4174)

Windows 7 Professional (64)

Intel(R) Centrino(R) Ultimate-N 6300 AGN 

8CET65WW (1.45) BIOS

 

The problem:

Basically, my wifi was working when I shut the laptop down one night, but then wasn't the next morning. I bought the T420s refurbished (no warranty) and haven't had any wifi problems in the 2 years I've had it. It's a great laptop. I just need the wifi to work again.

There's a red X on the wifi icon and no connections are detected. Windows Network Diagnostics can't identify the problem.

The wifi light at the lower right of the screen doesn't light. The bluetooth light does come on at bootup but then goes out.

The adapter is shown in Device Manager as working properly. It's enabled in BIOS.

Wireless is shown as off in the Windows Mobility Center, and the 'Turn wireless on' button is greyed out.

The radio switch stopped working (tried it about a year ago with no problem, but does nothing now).

The adapter pings fine with no losses.

There are no problems when connecting to the internet via ethernet cable.

 

What I've tried:

Disabled and reenabled the adapter.

Uninstalled and reinstalled the adapter.

Turned off 'Allow the computer to turn off this device to save power.'

Downloaded and installed the latest drivers from Lenovo.

Downloaded and updated the BIOS.

Downloaded and installed the latest drivers from Intel.

Disabled and reenabled all network hardware in BIOS.

Downloaded and installed Lenovo Power Manager and HotKeys. The Fn+F5 Wireless Radio Control says the radio switch needs to be in the on position. It is. The switch does nothing.

Downloaded and installed Lenovo Diagnostics. Diagnostics  threw warnings for every wireless test. The result code is WWF007000-WNBZDJ and the final result code is W12EUUDWX-DLEX78. These are worthless unless you are a technician. Any out there who want to shed some light on these codes?

 

I think I've tried just about every possible fix I could find on the internet short of reinstalling the OS or opening up the laptop. I suspect the adapter is bad, but the ping and wired connection seem to logically oppose that suspicion. Any further ideas or info would be greatly appreciated.  

Check out current deals!


Shop current deals

Top Kudoed Authors