Showing results for 
Search instead for 
Did you mean: 
Paper Tape
Posts: 2
Registered: ‎09-29-2016
Location: AT
Views: 375
Message 1 of 2

T420s throttels CPU on AC to 0.78GHz

My T420s throttels its CPU while on AC Power to 0.78GHz.


It doesnt maka a difference, wheather it is 90W or 65W AC Power.


This effect occours when the battery is inside and also when the battery is removed, but only on AC plugged in.

When the laptop runs on battery, the cpu seams to work normal.


I also tried another battery, because i have two T420s. Also no difference.


The latest bios 1.41 is installed.

I have speedstep set to max performance - no change

I have deactivated speedstep - no change

I have reseted my BIOS settings - no change

I have tried different OS (Win 10, Ubuntu 16.04) - no change

I have tried to downgrade the BIOS - no chance to manage this (If anyone has an idea, it is welcome)


I did Cinebench benchmark and it showed, that on battery, the laptop runs fine. Only when AC Power is plugged in, I have the troubles. Any recommendations or solutions are welcome!




Paper Tape
Posts: 2
Registered: ‎09-29-2016
Location: AT
Views: 270
Message 2 of 2

Re: T420s throttels CPU on AC to 0.78GHz

So I finally was able to solve this problem, but only with great efford.


In the end this problem seems to occur due to a hardware mailfunction on the mainboard. I guess it has something to do with the energy saving concept.

Nevertheless it I was not able find out what part on the mainboard was broken and so I bought a used MB and replaced it.

With the "new" mainboard, the laptop works just fine.


Check out current deals!

Shop current deals

Top Kudoed Authors