English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

17 Posts

04-27-2010

US

77 Signins

381 Page Views

  • Posts: 17
  • Registered: ‎04-27-2010
  • Location: US
  • Views: 381
  • Message 1 of 19

T420s with NVidia -- how to disable "GPU ready to save power" message?

2013-07-13, 16:10 PM

I have two T420s laptops, each with the NVidia Optimus option. On one of them, I regularly get an annoying popup message stating "GPU Ready to save power", typically when coming out of sleep. I've googled it and looked through the forums and knowledge base, and I've tried all kinds of settings in the NVidia control app, but I can't get rid of the message. I've also compared the NVidia configurations on the laptops, and I can't see any differences.

 

Can anybody tell me how to get rid of this message (or why I should care about it)? It seems to be there just to annoy me.

 

Thanks!

Reply
Options

1491 Posts

05-29-2010

SG

2871 Signins

58967 Page Views

  • Posts: 1491
  • Registered: ‎05-29-2010
  • Location: SG
  • Views: 58967
  • Message 2 of 19

Re: T420s with NVidia -- how to disable "GPU ready to save power" message?

2013-07-15, 15:39 PM

Hi dwhiting56

Could you try to update your Intel iGPU and NVIDIA dGPU with the latest official driver? I only happened to see this message when I come out of sleep when my W520 is connected with a VGA monitor.

Peter :cathappy::heart: 

W520 (4284-A99)

Does someone’s post help you? Give them kudos as a reward, as they will do better to improve | Mark it as solved if the solution works for you, so it could be reference for others in the future | Please do not email me regarding technical problems, you could post it in the forum

=====================================

Sound Enhancement (Post comments, share mixes, etc.)

Dolby Home Theater v4 ; IdeaPad Slate Tablet

Reply
Options

24 Posts

12-07-2012

Philadelphia, PA

41 Signins

222 Page Views

  • Posts: 24
  • Registered: ‎12-07-2012
  • Location: Philadelphia, PA
  • Views: 222
  • Message 3 of 19

Re: T420s with NVidia -- how to disable "GPU ready to save power" message?

2013-12-08, 5:39 AM

Did you ever figure out this message?

I always get this "GPU ready to save power" and right afterwards something funky may happen to my Lenovo W520. Like the computer screen flickers or goes into Hibernation Mode randomly (and even wakes up from its Hibernation randomly, like minute or hour later).

 

It looks like this message is created by Nvidia Optimus but not sure how to make it stop. Hoping stopping it, will stop by random sleep/hibernation when Im working.

Reply
Options

2 Posts

01-31-2014

US

9 Signins

37 Page Views

  • Posts: 2
  • Registered: ‎01-31-2014
  • Location: US
  • Views: 37
  • Message 4 of 19

Re: T420s with NVidia -- how to disable "GPU ready to save power" message?

2014-01-31, 19:32 PM

I have a T530 with the Nvidia NVS 5400M running Windows 8.1 and am getting this "GPU ready to save power" popup up to several times a minute. All screens flicker, then refresh with everything moved to the main display once they all come back up. Killing my experience here - makes this setup almost unusable. All drivers are current.

 

Someone PLEASE post a suggestion on how to fix? I've tweaked every setting I could think of.

 

-V

Reply
Options

24 Posts

12-07-2012

Philadelphia, PA

41 Signins

222 Page Views

  • Posts: 24
  • Registered: ‎12-07-2012
  • Location: Philadelphia, PA
  • Views: 222
  • Message 5 of 19

Re: T420s with NVidia -- how to disable "GPU ready to save power" message?

2014-01-31, 20:07 PM

Do you have an mSata as your OS drive?

Im just curious, im not sure whats unusual about my system to make it do this. Thats the only thing, but lots of people claim they running mSATA fine as OS (the W530 manual doesnt gaurentee it as an OS drive though).

I've fought for Lenovo for over a year to replace it for another laptop (they replaced mobo/cpu/memory 3 or 4 times already. I just wanna cry lol as I spent $1700 on the system and have never used my laptop. Its been with them for past 1 month so hoping they replace with another laptop since its under warranty.).

 

The first time it was a crimpled connector which was causing separate black screens they said. I stil get the random black screens followed by GPU ready to save power. or random sleeping or random black screens that never come back (not even show GPU ready to save power). The Nivida drivers are appropriate and I tried various newer drivers as well (Lenovo system update sometimes holds back on absolute latest intel drivers to keep things working together i believe.).

Reply
Options

2 Posts

01-31-2014

US

9 Signins

37 Page Views

  • Posts: 2
  • Registered: ‎01-31-2014
  • Location: US
  • Views: 37
  • Message 6 of 19

Re: T420s with NVidia -- how to disable "GPU ready to save power" message?

2014-01-31, 20:22 PM

Nothing custom at all. T530 as delivered out of the box.

 

Everything was working perfectly for the past year until about a week ago when I updated to Windows 8.1. No hardware changes at all, and the laptop is sitting in the same docking station in which it's been for months now. This is clearly a software issue.

 

Config is two Samsung S27B350 monitors connected to the docking station's DV ports - driven by the 5400M. A third S27B350 is on the docking station's VGA port - driven by the Intel HD Graphics 4000. Laptop lid closed (Windows power setting to do nothing on lid close).

 

After the "GPU ready to save power" flicker, everything gets moved to the primary monitor, which is one of the two on the DV ports/NVS 5400M.

 

Again, everything was fine until Win 8.1.

 

-V

Reply
Options

24 Posts

12-07-2012

Philadelphia, PA

41 Signins

222 Page Views

  • Posts: 24
  • Registered: ‎12-07-2012
  • Location: Philadelphia, PA
  • Views: 222
  • Message 7 of 19

Re: T420s with NVidia -- how to disable "GPU ready to save power" message?

2014-02-02, 3:11 AM

Contact Nvidia to ask why the popup occurs as it seems initiated on their end.

I haven't seen any documentation on it. Google the error and this is the only match I think lol.

I dont think Lenovo knows anything about it.

Reply
Options

2 Posts

02-26-2014

Littleton, CO

1 Signins

7 Page Views

  • Posts: 2
  • Registered: ‎02-26-2014
  • Location: Littleton, CO
  • Views: 7
  • Message 8 of 19

Re: T420s with NVidia -- how to disable "GPU ready to save power" message?

2014-02-26, 3:16 AM

I have exactly the same problem.  Prior to converting from 8.0 to 8.1 did not have a problem.  A gain 3 moniters, I can turn on the laptop moniter but I don't use it so I turned it off.

 

"GPU ready to save power" but more than a flicker, screens go blank for 2-3 seconds, I can keep typing and nothing is lost.  Occasionaly a window will change screens.  Updated drivers nothing.

 

It sounds the same, very annoying, we need a fix

 

Reply
Options

1 Posts

06-18-2014

United States

4 Signins

25 Page Views

  • Posts: 1
  • Registered: ‎06-18-2014
  • Location: United States
  • Views: 25
  • Message 9 of 19

Re: T420s with NVidia -- how to disable "GPU ready to save power" message?

2014-06-18, 14:56 PM

I'm having the same problem with my T530 with NVidia. Did anyone ever figure out a solution to this? I'm trying to update some graphics drivers currently. 

Reply
Options

2 Posts

02-26-2014

Littleton, CO

1 Signins

7 Page Views

  • Posts: 2
  • Registered: ‎02-26-2014
  • Location: Littleton, CO
  • Views: 7
  • Message 10 of 19

Re: T420s with NVidia -- how to disable GPU ready to save power message?

2014-06-18, 16:42 PM

I tried various drivers, older and updated, nothing seemed to work. Finally I decided to just live with it, a real pain. It has been several weeks since it has happened (????), maybe I shouldn't say anything. I was using some intensive GIS programs, but I finished the project and have not used the GIS programs for awhile, maybe it is related. When I was having the problem I never saw any correlation with the operating programs.

Good luck

Ken Sweet
Kenco Minerals
Senior Geophysicist
USA

Moderator Note; private information edited to prevent possible abuse

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save