Showing results for 
Search instead for 
Did you mean: 
Paper Tape
Posts: 4
Registered: ‎11-25-2017
Location: DE
Views: 371
Message 1 of 2

T430 - Touchpad & Trackpoint stopped working

Hey there! Just today, a rather big problem came up on my T430: The Synaptics Ultranav Driver seems to have stopped working.

Keyboard is still working fine, and touchpad also works after uninstalling Synaptics Ultranav. Trackpoint never works and Touchpad stops working as soon as Windows (automatically) reinstalls Synaptics Ultranav. Both are enabled in BIOS. I've tried pretty much anything, from reinstlaling Synaptics drivers (multiple times) to updating BIOS. I'm at a loss here.

I'm absolutely positive that this is a problem on Synaptics' side. This is what their controls panel looks like:


As you see, touchpad and trackpoint are greyed out. Again, they're enabled in BIOS and I can rule out any hardware-side problem. Any kind of help would be highly appreciated.

Paper Tape
Posts: 4
Registered: ‎11-25-2017
Location: DE
Views: 348
Message 2 of 2

Re: T430 - Touchpad & Trackpoint stopped working

Huh, maybe I'm not that good with rulung out hardware-side problems because this might actually have been one. I just wanted to try removing and reconnecting the keyboard/trackpoint cable to see if it might have become loose. And voila - fixed the issue. I find it strange because the plug didn't feel loose at all. Whatever, consider this solved.

And we're back...

Move delayed but still coming

Learn More

Check out current deals!

Shop current deals

Top Kudoed Authors