Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

2 Posts

06-16-2016

UK

4 Signins

30 Page Views

  • Posts: 2
  • Registered: ‎06-16-2016
  • Location: UK
  • Views: 30
  • Message 1 of 1

T430 Trackpad Not Working?

2016-06-16, 15:52 PM

I was just using my ThinkPad as usual today and then Windows automatically updated the Synaptics drivers. This led to both the trackpad and trackpoints not working and I had to use an external mice to use navigate. I fixed the issue by rolling back the driver, which worked until the next restart. I tried to find a more permanent fix so I uninstalled the drivers and reinstalled it, but this didn't work and now the drivers are stuck installing. Additionally, because I uninstalled all the previous drivers, I cannot use those ones that work. What makes things worse is that using external mice no longer works so I am now restricted to navigating with the keyboard.

 

I've checked the device manager and it says that the 'device could not start (Code 10)' because 'the device is not in a valid state to perform the request'. 

 

Has anyone else had this issue? Or does anyone know how to rectify this, because otherwise my laptop is going to turn into (quite a heavy!) paperweight. I am reluctant to reinstall Windows incase it doesn't actually solve the issue.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms