English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

1 Posts

11-18-2017

HU

2 Signins

25 Page Views

  • Posts: 1
  • Registered: ‎11-18-2017
  • Location: HU
  • Views: 25
  • Message 1 of 2

T430 - Windows 10 Pro - extreme slow internet / system

2017-11-18, 19:40 PM

I have 1000mbps internet connection. When I booted my Laptop (T430) from a USB with Linux Mint and checked the internet speed, it was 800+ Mbps. With Windows 10 Pro it is only ~150Mbps.

Windows version: 1703

I had to restore my windows to this version because after the last bigger update (1709) the whole laptop was so slow that it was impossible to work with. The internet speed was only ~50-70Mbps.

Well, now the system fast enough that at least I can work on it. But still, 800+ vs 150 is a huge gap.

Any idea what should I do?

It is so annoying and disappointing that such an expensive laptop (even if it is 5 years old) with 16 GB RAM and with a Samsung SSD 850 Pro is totally useless. It is ridiculous.

Every driver is up to date. I am connecting to the internet via cable, wifi is turned off.

 

Reply
Options

6 Posts

04-22-2018

FI

12 Signins

104 Page Views

  • Posts: 6
  • Registered: ‎04-22-2018
  • Location: FI
  • Views: 104
  • Message 2 of 2

Re: T430 - Windows 10 Pro - extreme slow internet / system

2018-08-16, 11:40 AM

What happens to be your wireless adapter?

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save