English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

30 Posts

11-26-2012

UK

46 Signins

184 Page Views

  • Posts: 30
  • Registered: ‎11-26-2012
  • Location: UK
  • Views: 184
  • Message 1 of 8

T430 function keys not working

2012-11-29, 9:36 AM

This applies to both our T430's and our X230's on Windows 7 x86 SP1

 

We've downloaded all of the latest drivers from the Lenovo site (after realising that the Update Tool doesn't bring down everything up to date).

 

The OEM image out of the box works fine, pressing Fn+F3,F4, etc. performs the corresponding actions such as locking the screen, launching wifi, etc. But, when we apply a blank Windows image and install the drivers ourselves, not all of the hotkeys work.

 

The hotkeys that work are F4 (sleep), F7 (screen select), F8 & F9 (brightness) and F10, F11 & F12 (media keys)

The hotkeys that don't work are F3 (lock screen), F5 (wifi), F6 (communications) and the small hotkey button next to the mute button (in the OEM image, that launches the Lenovo control panel).

 

I've looked around the forums and come up with this install order, which still doesn't seem to work:

 

Chipset Driver
AMT Driver
Intel RST
Card Reader
Audio Driver
Camera Driver
Bluetooth
USB 3
Touchpad Driver
WLAN Driver
Fingerprint software

Power Manager

Hotkey Software
Wifi Driver

Access Connections
Comm. Utility

Active Protection
Solution Center

RapidBoot
Graphics Drivers (Intel & Nvdidia)
WiDi

 

Any help would be appreciated!

Solved! See the solution
Reply
Options

229 Posts

05-22-2012

Hong Kong

470 Signins

2944 Page Views

  • Posts: 229
  • Registered: ‎05-22-2012
  • Location: Hong Kong
  • Views: 2944
  • Message 2 of 8

Re: T430 function keys not working

2012-11-29, 13:06 PM
Hi TheMagic89,

As suggested in other thread, you are missing power management driver. Since you are using 3rd party OS so you will lost one key recovery function. In windows environment, you can use ThinkVantage button (the black one next to volume) to call out Lenovo Solution Center application after installation.

ThinkPad Power Management driver for Windows 7 (32-bit, 64-bit), Vista (32-bit, 64-bit), XP (32-bit, 64-bit) - ThinkPad
http://support.lenovo.com/en_US/downloads/detail.page?LegacyDocID=MIGR-4GXPEG

Lenovo Solution Center
http://support.lenovo.com/en_US/downloads/detail.page?LegacyDocID=MIGR-61432#lsc

Fred
T61 + X201i
Reply
Options

30 Posts

11-26-2012

UK

46 Signins

184 Page Views

  • Posts: 30
  • Registered: ‎11-26-2012
  • Location: UK
  • Views: 184
  • Message 3 of 8

Re: T430 function keys not working

2012-11-29, 17:20 PM
thanks for the reply.

is the power management driver not the same as the software?

also, what order should that be put into the build?

thanks in advance
Reply
Options

229 Posts

05-22-2012

Hong Kong

470 Signins

2944 Page Views

  • Posts: 229
  • Registered: ‎05-22-2012
  • Location: Hong Kong
  • Views: 2944
  • Message 4 of 8

Re: T430 function keys not working

2012-11-30, 2:02 AM
Hi TheMagic89,

Power Management driver supports basic power management feature like sleep or hibernation. Power Manager is program to provide further feature like customise power plan, display battery info and even preset the behaviour of charging battery. There's no official procedure for installation sequence, but personally i would install chipset -> power management driver, then other programs.

Fred
T61 + X201i

0 person found this solution to be helpful.

This helped me too

Reply
Options

30 Posts

11-26-2012

UK

46 Signins

184 Page Views

  • Posts: 30
  • Registered: ‎11-26-2012
  • Location: UK
  • Views: 184
  • Message 5 of 8

Re: T430 function keys not working

2012-11-30, 13:04 PM
After the first attempt, it worked perfectly.

I'll carry on testing to ensure it's working correctly, thanks for your help, appreciate it!
Reply
Options

30 Posts

11-26-2012

UK

46 Signins

184 Page Views

  • Posts: 30
  • Registered: ‎11-26-2012
  • Location: UK
  • Views: 184
  • Message 6 of 8

Re: T430 function keys not working

2012-12-03, 11:07 AM

I'm happy to report that the above almost works... the Fn+F6 combination for Comms Utility works, albeit after a long wait of about 30 seconds or so. But, the Fn+F4 (sleep) no longer works.

Very weird!

Reply
Options

1 Posts

02-10-2013

NC, US

3 Signins

9 Page Views

  • Posts: 1
  • Registered: ‎02-10-2013
  • Location: NC, US
  • Views: 9
  • Message 7 of 8

Re: T430 function keys not working

2013-02-10, 12:01 PM

my E535 function key F8 not working when I was trying to install virtual PC.  Eventually I used Fn+Shift+F8 to work.

Reply
Options

1 Posts

04-18-2014

calif

2 Signins

17 Page Views

  • Posts: 1
  • Registered: ‎04-18-2014
  • Location: calif
  • Views: 17
  • Message 8 of 8

Re: T430 function keys not working

2014-04-18, 18:43 PM
make sure you reinstall the ultranav driver.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete