English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

2 Posts

08-19-2017

FR

3 Signins

30 Page Views

  • Posts: 2
  • Registered: ‎08-19-2017
  • Location: FR
  • Views: 30
  • Message 1 of 3

T430 power on issue after few drops of water

2017-08-19, 12:50 PM

Hello all,

I need your help to troubleshoot my T430 that is not powering on anymore :s

 

yesterday, some water dropped from a window onto the desk where my T430 was sitting. I didn't notice any water dropped on the laptop, just close to it. When I turned on the laptop I got some unexpected USB device detected and error message saying the device could not be configured. I turned the laptop off then back on, then the screen wasn't working anymore. When taking the laptop to plug it to an external monitor, I noticed some water at the bottom of the laptop!! I unplugged the battery and AC, removed all devices (RAMs, HDD, keyboard, optical drive) and let it dry for 24h, sometimes using hairdryer.

 

Now the laptop do not power at all anymore, when I press the power button, I hear no beep, no fan turning. Here are the symptoms:

- with or without battery on, when I plug the AC, the battery indicator blinks 3 times

- when I press the power button on, the power indicator blinks 3 times

- when AC and battery are plugged, there is no indication that battery is charging

- when AC and/or battery is plugged, there is no power coming from the yellow USB plug

- I tried reseting the laptop, emptying capacitors, unplugging the CMOS battery, and no change

- I tried power up without keyboard by shorting to ground pin 19 of keyboard connector and same thing happens, the battery indicator blinks 3 times. Same thing with or without RAM installed.

 

Does anyone have any idea of what I could do to test it further. I'd like to avoid replacing the system board ...

 

Thanks for your help!

Nic

Reply
Options

2 Posts

08-19-2017

FR

3 Signins

30 Page Views

  • Posts: 2
  • Registered: ‎08-19-2017
  • Location: FR
  • Views: 30
  • Message 2 of 3

Re: T430 power on issue after few drops of water

2017-08-28, 13:47 PM

Hello,

 

few days later, when I power-up the computer, the fan is turning on, but there is nothing displayed on the screen.

 

Any idea anybody ?

 

Thank you!

Reply
Options

9605 Posts

12-27-2009

CA

3310 Signins

95263 Page Views

  • Posts: 9605
  • Registered: ‎12-27-2009
  • Location: CA
  • Views: 95263
  • Message 3 of 3

Re: T430 power on issue after few drops of water

2017-09-01, 4:24 AM
Unfortunately it's almost certainly the motherboard.

If you remove all of the RAM sticks, does it make a 1-3-3-1 beep sequence?

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save