cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Gwypaas
Paper Tape
Posts: 1
Registered: ‎06-23-2013
Location: Sweden
Views: 9,560
Message 1 of 3

T430s SDHC card reader not working

Hi, I recently bought a T430s and when I tried to insert a SD card it did not show up in my computer. I've tried 3 different SD cards the sizes are16 gb, 32 gb and 2 gb and neither of them shows up, to make sure the problem is not in the SD card I tried using the SD cards in 2 cameras and 2 other laptops. In all those devices the cards works.

I have tried installing these drivers from this thread https://forums.lenovo.com/t5/T400-T500-and-newer-T-series/New-T430s-4-in-1-express-card-SD-reader-mi... but it did not work.

 

I also tried following the instructions in this thread http://forums.lenovo.com/t5/T400-T500-and-newer-T-series/T430s-card-reader-cannot-read-16-GB-SDHC-ca... but that did not help either.

According to the device manager the Ricoh PCIe SDXC/MMC Host Controller is working correctly. The Ricoh SD Disk Device is also working correctly.

 

Whenever I insert the SD card the Sound for a new device plays and when i remove the SD card the removal sound plays. How can I fix this? I'm going away for 7 weeks with my laptop so I need to fix it ASAP and I dont have time to send the laptop to Lenovo.

 

EDIT:


I uninstalled Ricoh Media driver and now 1 of the cards show up but Windows complains about that it needs to be formatted, but the size is 0 so that doesn't work either. Tried installing the driver again and now they show up in the device manager again and proudly says that they are working but the SD card still doesn't show up so I can read the files on it.

 

EDIT 2:
If I go into the device manager and forcibly update the the Ricoh SD Disk Device then it says:
Disc: Disc 1
Type: Removable
Status: Online
Partitiontype: MBR (Master Boot Record)
Capacity: 15807 MB
Non-allocated space: 0 MB

Allocated space: 0 MB

 

For the 32 gb SD card everything is the same but instead it says "Capacity: 30828 MB".

 

EDIT 3:
When the SD card is inserted a storage device pops up in the device manager. The name of the device is just "Unknown device" and the status is that it can't find any installed drivers for the device.

SeniorGuru
Posts: 2,719
Registered: ‎12-22-2008
Location: CA
Views: 9,515
Message 2 of 3

Re: T430s SDHC card reader not working

I'm experiencing a similar situation with my 1-year old T430s. The built-in card reader was working fine until recently when it stopped working.

 

Now the built-in SD card reader doesn't recognize SD cards that are recognized in external USB adapters.

 

Device Manager shows Ricoh PCIe SDXC/MMC Controller when an SD card is inserted into the card reader but neither Windows Computer Management/Disk Management nor Windows Explorer show the drive. Device Manager indicates that the driver is up-to-date (v6.10.10.32 25May11.)

 

When I put the same SD cards into an external USB adapter they're recognized by Windows, assigned a drive letter and visible to Windows Explorer as well as other applications.

 

Do I have a defective card reader? 

__________________________________________________
Cheers... Dorian Hausman • ca.gif English community
X1C6, E470, Y900s, [R.I.P. X1C2, T430s, TPT2, SL500, X61s, T60p, A21p, 770, 760ED... 5160, 5150... S360/30]
tripplec
Bit Torrent
Posts: 2,379
Registered: ‎03-08-2012
Location: CA
Views: 9,500
Message 3 of 3

Re: T430s SDHC card reader not working

You may find 6.20 drivers as I did but are not digitally signed but worked until rebooting the next time due to signature checking.

those drivers appear to be the same is my Ricoh reader. Very old version. Other OEM have the new drivers but digitally sign for their systems.
T520 Model 4239 Intel(R) Core(TM) i7-2860QMbr>; Nvidia NVS 4200M Win 10 64bit
Z70-80 I7 - 5500U 16GB GB - 1TB HD Win 10 64bit FHD 17.3", G840 w/2GB

Check out current deals!


Shop current deals

Top Kudoed Authors