English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

4 Posts

07-31-2013

CZ

19 Signins

131 Page Views

  • Posts: 4
  • Registered: ‎07-31-2013
  • Location: CZ
  • Views: 131
  • Message 1 of 1

T430s - [Solved?] Wireless hardware is not bound to transport driver (Centrino 6205, Win7x64)

2013-07-31, 8:45 AM

Hello,

 

after clean install of my new T430s using System Update everything worked quite well, except for terrible DPC latency when loading web pages (crapping sound). Therefore I changed LAN driver to 11.10.84.0 from Lenovo (83rw15ww) and latencies went down (this driver has been recommended in some online forum).

 

Few days later I was on WiFi and latency spiked up again, but this time all the time above 8000µs - even when idle. I started to play with devices in Device Manager and ultimately reinstalled WiFi driver to Lenovo's 15.6.1, then Intel's 15.8.0. The most recommended driver from HP I was unable to install, so no harm there :)

 

Not sure when, but somewhere since this point I don't see wireless networks any more. Driver is fine (no yellow ? or !), wireless card is fine (replaced by spare one from my "HW guy"), all drivers has been reinstalled MANY times. When I try to add WLAN manually, Win7 says "Unexpected Error". Diagnostic tool from Intel says "Wireless hardware is not bound to transport driver". In Fn+F5 I see WiFi as off and I can't turn it on (unlike Bluetooth, which works well). Windows Diagnostics says there's an issue with a driver (sorry if I don't use exact words, my Win7 is not EN). I don't see this card anywhere in "ipconfig". There's no difference in diagnostics whether the wireless switch is on or off.

 

I read almost everything I was able to google about similar issues. I tried various drivers from both Lenovo (manual download from Lenovo website as well as using System Update) and Intel, both with and without Access Connections. I tried to remove the device from Device Manager and let Windows to find it again. I reinstalled LAN driver, tried to update BIOS (was already updated), tried to reset various stuff using "netsh" command, deleted Intel/Wireless dir in [username]/AppData, all this with/without reboots in between. Tried to play with card settings (in Device Manager), with power settings (both Windows and Power Manager), with on/off switch on a side of the laptop. I tried System Restore, which ended by error for all meaningful points. Nothing. All this on 3 different WLAN networks (2.4 GHz).

 

My last thought is to reinstall Windows from scratch, but it takes me at least 2 whole days to set everything up as I use a boatload of different work stuff for different customers.

 

My current WiFi driver, according to Driver tab in Device Manager for Intel Centrino Advanced-N 6205, is 15.4.1.1 from January 23, 2013 (thru System Update). The more current one from Intel is 15.7.0.3 from April 18, 2013.

 

Thank you in advance for any suggestions, tips or help.

 

EDIT

Just for the heck of it I switched wireless ON at home and suddenly my home WiFi network appeared in Win7 WiFi management (no AC). The last driver I installed was thru System Update, twice. Never restarted immediately, always after a while.

 

So I ran System Update again and it offered me available driver for WiFi (again!) and Access Connections. The online utility from Intel also offered me available drivers. I still have WiFi driver 15.4.1.1 (23.1.2013). To be honest I'm little affraid to update one or the other, as I did it so MANY times in past 30 hours with no effect.

 

The only difference I noticed is a new wireless device was available - Microsoft Virtual WiFi Miniport Adapter. It may be because of my Checkpoint Endpoint Security VPN software, but last time I saw this adapter was just before I lost all the wireless networks.

 

As much as I'm relieved it's working again, as a programmer I'm not happy about it, because I don't know WHY it's working now, when I didn't do anything for it since my last try. I only kept the wireless switch off for a fair amount of time.

 

Oh, and DPC latency stays below 300µs (up to 500µs is OK).

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete