cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MyLenovos
Paper Tape
Posts: 2
Registered: ‎01-21-2017
Location: US
Views: 4,786
Message 1 of 2

T430s not recognizing USB 3.0 (SS) - Windows 7

Lenovo T430S

OS: Windows 7 Pro

 

The yellow USB works perfectly

 

The two blue USB's, both with "SS" do not work.

*When plugging in a mouse nothing happens.  The mouse does not have power and the OS does not recognize. 

*When plugging in a thumb-drive the red light on the thumb drive illumintes then goes out.  Nothing shows as recognized with the OS. 

 

Device manager has all hardware with drivers.  

In Device Manager, under Under USB Controlers, one is listed as, "Unknown Device."  When I try to update the drive it says its "Intel USB 3.0 Root Hub"

IUSB3\ROOT_HUB30&VID_8086&PID_1E31&REV_0004&SID_21FB17AA
IUSB3\ROOT_HUB30&VID_8086&PID_1E31&REV_0004
IUSB3\ROOT_HUB30&VID_8086&PID_1E31

I downloaded USB drivers for Lenovo T430s from lenovo.com

*Intel(R) USB 3.0 eXtensible Host Controller

I also tried uninstalling all USB drivers and rebooted and also nothing has changed. 

BIOS has USB settings all turned on (some were auto originally).

 

MyLenovos
Paper Tape
Posts: 2
Registered: ‎01-21-2017
Location: US
Views: 4,657
Message 2 of 2

Re: T430s not recognizing USB 3.0 (SS) - Windows 7

Seems this stumped most everyone.

 

Fortunalty I had another HDD and as I was searching for the right drivers to get WiFi to work the USB 3.0 drives started working.  When I compared the Device Manager I noticed that "Intel(R) USB 3.0 Root Hub" was present using the HDD where the USB 3.0 worked and missing from the other HDD.

 

I downloaded the drivers from Intel (rather than from Lenovo as I did previously) and I was able to update drivers (rather than running a Setup.exe) 

https://downloadcenter.intel.com/download/21129/USB-3-0-Driver-Intel-USB-3-0-eXtensible-Host-Control...

 

As an aside, both HDD's had "Intel(R) USB 3.0 eXtensible Host Controller" installed prior to the fix so some correct Intel USB 3.0 drivers loaded, but but not all. 

Check out current deals!


Shop current deals

Top Kudoed Authors