cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
LenovoUser2019
Paper Tape
Posts: 2
Registered: ‎12-23-2018
Location: US
Views: 541
Message 1 of 3

T440P - Bios Won't Update From 2.24 to 2.5.1

I have a T440P with BIOS version 2.24.

 

I have tried flashing to the latest BIOS (2.5.1) several times using the update utility, but it never actually ends up working.

 

The initial dialog boxes (i.e. warnings to not turn off computer, etc.) and command console will come up briefly, but then it shuts down the system and nothing is updated when I check upon reboot.

 

Does anyone know why this is happening?

 

I'm hoping that if I can get the BIOS to flash to this version, I won't have issues booting up (where I have to remove battery and CMOS battery to drain before booting up).

 

Here's the log:

 

[2018/12/23 1:59:18]
OS = Windows 10 64bit
Driver Loading....Done
System BIOS Version -> GLET70WW
Applying BIOS Version -> GLET97WW
System EC Version -> GLHT29WW
Applying EC Version -> GLHT29WW
AC adapter/Battery check....OK.

BIOS Flashing....BIOS Flash completed.

Community SeniorMod
Community SeniorMod
Posts: 10,283
Registered: ‎01-01-2010
Location: US
Views: 514
Message 2 of 3

Re: T440P - Bios Won't Update From 2.24 to 2.5.1

You are several versions behind.  I have had trouble in the past when changing several levels at once, especially when there are multiple EC levels involved..  I would consider doing the update to an intermediate level (maybe two) before going all the way.  Here is older version history:

https://pcsupport.lenovo.com/us/en/products/LAPTOPS-AND-NETBOOKS/THINKPAD-T-SERIES-LAPTOPS/THINKPAD-...

 


Rich


I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo.
LenovoUser2019
Paper Tape
Posts: 2
Registered: ‎12-23-2018
Location: US
Views: 503
Message 3 of 3

Re: T440P - Bios Won't Update From 2.24 to 2.5.1

That worked Rich.

I started at UEFI 2.26/ECP 1.08. At first I got a warning that it was older than the current ROM.

However, because my BIOS was showing 2.24 in MSINFO I still tried it anyway.

Sure enough, it started the process and flashed to that version without any issues. So then I further took your advice and repeated the flashing in phases (may have been overkill, but wanted to be safe):

UEFI 2.26 | ECP 1.08
UEFI 2.28 | ECP 1.08
UEFI 2.36 | ECP 1.11
UEFI 2.44 | ECP 1.12
UEFI 2.51 | ECP 1.12

Now I'm all good.

Hopefully this helps others as well. Thanks again!

Check out current deals!


Shop current deals

Top Kudoed Authors