English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

12 Posts

07-31-2015

Toronto

18 Signins

147 Page Views

  • Posts: 12
  • Registered: ‎07-31-2015
  • Location: Toronto
  • Views: 147
  • Message 1 of 34

T440s WWAN no longer working on Windows 10 Pro

2015-07-31, 13:46 PM

2 days ago I upgraded to Win 10 Pro, yesterday I went to use my mobile broadband connection (4G) and noticed I wasn't able to "see" the cellular connection or activate it anywhere.

 

Checking in the device manager I see the hardware (Sierra Wireless, etc), although strangely the driver is from Microsoft (Generic Broadband Device).  

 

Nothing I do seems to be able to make it work, I've uninstalled the drivers, rebooted, downloaded the current Lenovo driver package (which supposedly has Windows 10 drivers), it installs fine but still no mobile broadband is available to me.

 

I use this feature a lot, and would really like a solution to this... 

 

Thanks

 

Attached is a screen shot of the current driver situation:

 

cellular (Large).jpg

Reply
Options

6272 Posts

10-29-2009

NC

17576 Signins

159820 Page Views

  • Posts: 6272
  • Registered: ‎10-29-2009
  • Location: NC
  • Views: 159820
  • Message 2 of 34

Re: T440s WWAN no longer working on Windows 10 Pro

2015-07-31, 16:50 PM

We are checking on this.

Did you upgrade from Win7, or Win8.1?

Reply
Options

12 Posts

07-31-2015

Toronto

18 Signins

147 Page Views

  • Posts: 12
  • Registered: ‎07-31-2015
  • Location: Toronto
  • Views: 147
  • Message 3 of 34

Re: T440s WWAN no longer working on Windows 10 Pro

2015-07-31, 17:11 PM
Upgraded from Win 8.1 x64 where BTW the WWAN was working great.
Reply
Options

7 Posts

08-03-2015

Israel

10 Signins

80 Page Views

  • Posts: 7
  • Registered: ‎08-03-2015
  • Location: Israel
  • Views: 80
  • Message 4 of 34

Re: T440s WWAN no longer working on Windows 10 Pro

2015-08-03, 13:14 PM

Hi, I have the same issue on 2nd gen X1 (3460-2SG) that after Win 10 upgrade (from Win & Pro 64) lost Mobile Network but has WiFi OK?

Looked for updated drivers but found none...

Looked in "Mobile accsses" tool in previous profiles i had, and it states  "device is not found" in front of the H5321 gw Mobile broadband driver.

I believe I'm talking about WWAn with Sim card.

Where do I find the card type and driver ver.?

Reply
Options

7 Posts

08-03-2015

Israel

10 Signins

80 Page Views

  • Posts: 7
  • Registered: ‎08-03-2015
  • Location: Israel
  • Views: 80
  • Message 5 of 34

Re: T440s WWAN no longer working on Windows 10 Pro

2015-08-03, 13:37 PM

Found adapter type:  FRU Ericsson H5321w WWAN Module

Driver ver. 8.2.5.0

Reply
Options

12 Posts

07-31-2015

Toronto

18 Signins

147 Page Views

  • Posts: 12
  • Registered: ‎07-31-2015
  • Location: Toronto
  • Views: 147
  • Message 6 of 34

Re: T440s WWAN no longer working on Windows 10 Pro

2015-08-05, 15:38 PM

Has there been any updates to this issue?  

 

It seems like this is quite simply could just be a driver issue... Even though the lenovo driver package says it has Windows 10 drivers, it doesn't seems like it has the correct drivers.  It's clear that if I force install the drivers for the Gobi windows doesnt' like them and reverts back to "Generic Broadband" drivers.

 

 

Reply
Options

7973 Posts

01-13-2008

US

77049 Signins

2175283 Page Views

  • Posts: 7973
  • Registered: ‎01-13-2008
  • Location: US
  • Views: 2175283
  • Message 7 of 34

Re: T440s WWAN no longer working on Windows 10 Pro

2015-08-05, 17:24 PM

@rgagin

 

The below may apply to your situation:

 

  • H5321gw Mobile Broadband Device
  • C5621gw Mobile Broadband Device

Affected Systems;

  • ThinkPad L430
  • ThinkPad L530
  • ThinkPad S230u
  • ThinkPad S430
  • ThinkPad T430, T430i, T430s, T430si
  • ThinkPad T530, T530i
  • ThinkPad W530
  • ThinkPad X1 Carbon (Type 34xx)
  • ThinkPad X230, X230i
  • ThinkPad Edge S430

If the card's firmware hasn't been updated before upgrading to Windows 10 the card will produce a yellow bang in device manager and not function.  The current firmware doesn't allow itself to be installed running Windows 10 resulting in the system having to be rolled back to the previous OS, the firmware installed and then upgraded again to Windows 10.

 

Link to Firmware;

http://support.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-x-series-laptops/thinkpad-x23...

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English


Using Browser Search to find your answers in Lenovo and Moto Community


Reply
Options

12 Posts

07-31-2015

Toronto

18 Signins

147 Page Views

  • Posts: 12
  • Registered: ‎07-31-2015
  • Location: Toronto
  • Views: 147
  • Message 8 of 34

Re: T440s WWAN no longer working on Windows 10 Pro

2015-08-05, 17:49 PM

That's a much, much older card then I have... so that will not work for me.

 

Thanks anyway.

 

The problem here seems to be purely driver related... Even though Lenovo lists driver packs for Win 7, 8, 8.1 and 10... 

 

What I just noticed was that the driver version is actually the same.  Almost as if they just repackaged the same old driver.  

drivers.jpg

Reply
Options

6272 Posts

10-29-2009

NC

17576 Signins

159820 Page Views

  • Posts: 6272
  • Registered: ‎10-29-2009
  • Location: NC
  • Views: 159820
  • Message 9 of 34

Re: T440s WWAN no longer working on Windows 10 Pro

2015-08-05, 19:02 PM

NOTORIOUSVR

 

Can you please post a screenshot of Device Manager showing the "Driver" tab of the Sierra Wireless device?

 

One of my colleagues updated his T440s with Sierra WWAN and ended up with driver version 14.9.10221.0.  He did not manually install it, that's just what he ended up with after the Win10 upgrade.  And WWAN is working OK on Win10.

 

So we think this must be some driver problem, now we are checking to see where that 14.9.10221.0 driver came from, and why you apparently didn't end up with the same version after your Win10 upgrade.  And why this version doesn't seem to correspond to the version on the website.  Anyway, we are still investigating this.

Reply
Options

12 Posts

07-31-2015

Toronto

18 Signins

147 Page Views

  • Posts: 12
  • Registered: ‎07-31-2015
  • Location: Toronto
  • Views: 147
  • Message 10 of 34

Re: T440s WWAN no longer working on Windows 10 Pro

2015-08-05, 19:16 PM

It certainly seems to be a driver thing... here is the screenshot, as you will see the driver is from Microsoft, and although in the device manager it says it's a Sierra Wireless EM7355, the driver is not and is a Generic MS driver:

 

driver_tab.jpg

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete