cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Community SeniorMod
Community SeniorMod
Posts: 11,882
Registered: ‎06-06-2011
Location: RU
Views: 2,724
Message 11 of 34

Re: T440s WWAN no longer working on Windows 10 Pro

win10 as well win8/8.1 don't need manufacturer drivers for LTE modems in the MBIM mode. OSs use their own MBIM drivers. It's enough to use Mobile Broadband service and connection establishement.



x220 • Gobi 2000 3g | hdd, msata ssd, wwan, wifi, gps -- unique hand-made config
ThinkPad 25 Special Anniversary Edition. #retro. Signed by D.Hill
T470p | X1 Carbon Gen3 | Miix 2 10" | Yoga Tablet 2-1050F (Android) + BT Keyboard
ThinkPad Stack • 2.4/5 Wireless Router, HDD 1 TB, BT Speaker, Power Bank, Mobile Projector

Do it well, worse becomes itself

Communities:   English    Deutsche    Español    Portugues    Русскоязычное    Česká    Slovenská    Українська   Moto English

Community SeniorMod
Community SeniorMod
Posts: 7,056
Registered: ‎01-13-2008
Location: US
Views: 2,711
Message 12 of 34

Re: T440s WWAN no longer working on Windows 10 Pro


@NOTORIOUSVR wrote:

That's a much, much older card then I have... so that will not work for me.

 

...

NOTORIOUSVR,

 

My reply was intended for @rgagin.  I was waiting for a reply - to verify that they have a different issue than you - before splitting the posts out to another thread.

 

I would have done that in the first place but I couldn't be sure that you weren't facing the same - or a related - issue.

 

Apologies for the noise,

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

  Communities:   English    Deutsch    Español    Português    Русскоязычное    Česká    Slovenská    Українська   Polski    Moto English

rgagin
Paper Tape
Posts: 6
Registered: ‎08-03-2015
Location: Israel
Views: 2,690
Message 13 of 34

Re: T440s WWAN no longer working on Windows 10 Pro

Thank for the data. Tryed Ur suggestions and reverted back to win 7. Alas I lost wwan there to and had to uninstall and reinstall all drivers. Now I'm stuck with unresponsive data connection that's so slow it reminds me of 1980's dialup modems...
Toyed with the idea of upgrading again to win 10 but am not sure that will help in any way.
I feel a bit overwhelmed by all this...
Lenovo Staff
Lenovo Staff
Posts: 5,485
Registered: ‎10-29-2009
Location: NC
Views: 2,676
Message 14 of 34

Re: T440s WWAN no longer working on Windows 10 Pro

NOTORIOUSVR,

 

I tried this myself today.  My system is using generic driver and you can see from my screenshot I am connected by cellular to AT&T.

 

https://dl.dropboxusercontent.com/u/62276273/4g.jpg

 

Although this system has a Win10 preload, and was not upgraded from Win8.1.  My point is, generic Windows driver should be enough for Windows 10.  My next step is to put Win8.1 on this system, check the driver version that is installed on Win8.1, and then upgrade to Win10 to see what happens.  We are still investigating.

NOTORIOUSVR
Ctrl-Alt-Del
Posts: 12
Registered: ‎07-31-2015
Location: Toronto
Views: 2,627
Message 15 of 34

Re: T440s WWAN no longer working on Windows 10 Pro

Well that is certainly interesting.... I think I will have to bite the bullet and do a wipe/reinstall (which I had planned to do anyway). I just need to find some downtime. I've noticed a few other quirkes anyway since upgrading, not sure if there because of the upgrade (never liked upgrading versions of windows) or because of Windows 10 bugs.

If you find out anything else or need any other info I would be happy to share, otherwise I will update once I do the wipe and reinstall Win 10.

Thanks
rgagin
Paper Tape
Posts: 6
Registered: ‎08-03-2015
Location: Israel
Views: 2,604
Message 16 of 34

Re: T440s WWAN no longer working on Windows 10 Pro

NOTORIUSVR & Others

Glad to let you know my problem was solved. Like I said before i upgraded back to win7, updated firmware and drivers and than back to Win10. Had very slow connection that after digging around I found had to do with issues my provider had with my account.

After settling thoes issues- all works just fine.

 

Thanks for the help.

 

rgagin

NOTORIOUSVR
Ctrl-Alt-Del
Posts: 12
Registered: ‎07-31-2015
Location: Toronto
Views: 2,539
Message 17 of 34

Re: T440s WWAN no longer working on Windows 10 Pro

Well this weekend I re-installed Win 10 Pro as a clean install and it got me one step closer to getting the WWAN working. It recognized the card, and recognized the cellular network/operator name from the SIM but it consistently said Looking for signal and the bars were gray.

I downloaded the drivers from the website, and it took some time for the software to "configure" the cellular device (I guess it might have done a firmware update on it, but after that it worked!

I'm actually posting this reply using the WWAN.

Regards
PatriN
Fanfold Paper
Posts: 8
Registered: ‎08-17-2015
Location: GR
Views: 2,527
Message 18 of 34

Re: T440s WWAN no longer working on Windows 10 Pro

Hello all, I am facing the same issue with a T430 after upgrading from Windows 8.1 x64  to 10. My card is a Sierra MC8355 – Gobi 3000 and I cannot use my WWAN. Are we still waiting for an update, or the only solution is to revert back to Win 7/8.1..?

 

I also need to check my T500 which I upgraded to Windows 10 and has an Ericsson card. While on 8.1 the WWAN was functioning perfectly.

 

PatriN
Fanfold Paper
Posts: 8
Registered: ‎08-17-2015
Location: GR
Views: 2,511
Message 19 of 34

Re: T440s WWAN no longer working on Windows 10 Pro

I found out from another thread that this card is not supported on Win 10. So since my T430 is supported for upgrading to Win 10 but my WWAN is not, can I replace it with another one in order to restore this functionality..? If yes, which one is suggested..? Thank you...
Community SeniorMod
Community SeniorMod
Posts: 11,882
Registered: ‎06-06-2011
Location: RU
Views: 2,500
Message 20 of 34

Re: T440s WWAN no longer working on Windows 10 Pro

Hi, PatriN

Do you see wwan card related device in the Device Manager w/o card's drivers installed? If "yes", try to perform the installation of drivers for win8.

Do it manually from Device Manager, using update button:
- unpack package with drivers on the disk, refuse to install them
- press "update" button
- navigate the folder where files from package are stored
- try to install drivers



x220 • Gobi 2000 3g | hdd, msata ssd, wwan, wifi, gps -- unique hand-made config
ThinkPad 25 Special Anniversary Edition. #retro. Signed by D.Hill
T470p | X1 Carbon Gen3 | Miix 2 10" | Yoga Tablet 2-1050F (Android) + BT Keyboard
ThinkPad Stack • 2.4/5 Wireless Router, HDD 1 TB, BT Speaker, Power Bank, Mobile Projector

Do it well, worse becomes itself

Communities:   English    Deutsche    Español    Portugues    Русскоязычное    Česká    Slovenská    Українська   Moto English

Check out current deals!


Shop current deals

Top Kudoed Authors