English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

2 Posts

09-25-2019

BY

5 Signins

46 Page Views

  • Posts: 2
  • Registered: ‎09-25-2019
  • Location: BY
  • Views: 46
  • Message 1 of 2

T450 and Bluetooth Low Energy (BLE)

2019-09-25, 18:31 PM

It seems like Bluetooth Low Energy (BLE) doesn't work properly on my T450.

 

I use T450 BLE for searching BLE devices, connect to them, transfer some data, then disconnect.

My issue is: after cold boot (restart) of T450 all works fine BUT after some loops of BLE connect, data transfer, disconnect, I can't use BLE on the T450. Sometimes BLE devices stop to be found sometimes data transfer to be stopped.

If I use Bluetooth USB dongle (BT-UB40) and T450 all works perfectly.

 

I have Windows 10 (ver. 1903) with latest updates. All T450 drivers are up to date.

Also, I tried all the troubleshooting tips which I found but they don't help.

 

Will very appreciate for any help.

Reply
Options

2 Posts

09-25-2019

BY

5 Signins

46 Page Views

  • Posts: 2
  • Registered: ‎09-25-2019
  • Location: BY
  • Views: 46
  • Message 2 of 2

Re: T450 and Bluetooth Low Energy (BLE)

2019-10-02, 16:26 PM
I figured out that when Lenovo T450 received something about 20-40 packets > 128 bytes (in my case is 384 bytes), BLE stops working. If I use 128 bytes data packets to send from mobile devices to the laptop all works fine.
So the root cause of my issue is packets size.
Does anybody know why this happens and why Lenovo BLE stops working with big packets?

BTW, BLE MTU is 512 by default.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete