cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
marcissa
Fanfold Paper
Posts: 22
Registered: ‎02-10-2010
Location: USA
Views: 3,517
Message 1 of 7

T450s: 2100: Detection error on HDD0 (Main HDD)

Anyone experiencing this? I see a lot of older posts referring to this error. This is on a brand new machine.  Wondering if this is something that needs to be repaired or just a bug which could be fixed by an upcoming Bios update. 

 

Happens infrequently but sometimes I will come back to the laptop after walking away, and it will be at this error. 

Guru
Posts: 9,598
Registered: ‎12-26-2009
Location: CA
Views: 3,491
Message 2 of 7

Re: T450s: 2100: Detection error on HDD0 (Main HDD)

Do you have an SSD?

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
marcissa
Fanfold Paper
Posts: 22
Registered: ‎02-10-2010
Location: USA
Views: 3,489
Message 3 of 7

Re: T450s: 2100: Detection error on HDD0 (Main HDD)

Yes, the one that came with the unit.

Guru
Posts: 9,598
Registered: ‎12-26-2009
Location: CA
Views: 3,461
Message 4 of 7

Re: T450s: 2100: Detection error on HDD0 (Main HDD)

Try reseating the SSD; it's possible the connection is loose for some reason.

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
marcissa
Fanfold Paper
Posts: 22
Registered: ‎02-10-2010
Location: USA
Views: 3,457
Message 5 of 7

Re: T450s: 2100: Detection error on HDD0 (Main HDD)

I tried this. I opened it up and noticed that the plastic frame holding it in does not hold it firmly in place. So I put a small pieve of electric tape to make sure there is no give. Not 10 minutes after closing it and booting it did I get the same error. And I know with the tape there it was firmly set. This really sucks as I know if I call support they will have no answer and probable have me send it in for another one that does the same thing. 

Guru
Posts: 9,598
Registered: ‎12-26-2009
Location: CA
Views: 3,450
Message 6 of 7

Re: T450s: 2100: Detection error on HDD0 (Main HDD)

It's possible that the drive/connector/motherboard may just be failing. I'd let depot handle it if you have the time for it.

If you do send it in, clarify repeatedly that the issue is sporadic; otherwise they might just boot it once or twice and declare it problem-free.

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
marcissa
Fanfold Paper
Posts: 22
Registered: ‎02-10-2010
Location: USA
Views: 3,449
Message 7 of 7

Re: T450s: 2100: Detection error on HDD0 (Main HDD)

Will do, I think I may actually take it into an authorized repair center. Thereis on near me this way I can speak to someone about it. 

Check out current deals!


Shop current deals

Top Kudoed Authors