Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

10 Posts

08-28-2015

Germany

7 Signins

81 Page Views

  • Posts: 10
  • Registered: ‎08-28-2015
  • Location: Germany
  • Views: 81
  • Message 1 of 10

T450s Windows 7 clean installation fails - driver missing

2015-08-28, 6:52 AM

Hey  guys!

 

Since yesterday I'm a proud owner of my new Thinkpad T450s 20BWS40E00. It's an educational edition and was shipped without an operating system. I tried to install an Windows 7 SP1 x64 in UEFI-Mode, but sadly it fails because the Windows Setup couldn't locate any harddrive and demands an appropriate controller driver.

 

I tried the Intel Rapid Storage Technology Driver from the Lenovo support page, but it doesn't work. Also Google couldn't give my any hints. I wonder why I'm not able to find the correct driver.

 

I'll be very thankfull for any help and hints.

 

Cheers!

Reply
Answer
Options

10 Posts

08-28-2015

Germany

7 Signins

81 Page Views

  • Posts: 10
  • Registered: ‎08-28-2015
  • Location: Germany
  • Views: 81

Betreff: T450s Windows 7 clean installation fails - driver missing

2015-08-29, 5:25 AM

I've found the solution!

 

Windows 7 isn't cappable of USB 3.0 without any additional drivers, right? So my T450s isn't equippet with USB-2.0 "Only" Ports but with three USB-3.0 Ports. I've changed the USB-3.0 BIOS Feature from it's default "AUTO" setting to enabled. After changig it back to "AUTO" or "DISABLED" the Windows 7 Installer did what he was supposed to... It seems the Installer asked my to install the appropriate USB-3.0 Controller driver and not the SATA/AHCI-Driver.

 

Nevertheless! Thank you for you help!

Cheers!

Reply

Replies(9)
Options

66 Posts

10-21-2014

Denmark

61 Signins

885 Page Views

  • Posts: 66
  • Registered: ‎10-21-2014
  • Location: Denmark
  • Views: 885
  • Message 2 of 10

Re: T450s Windows 7 clean installation fails - driver missing

2015-08-28, 8:42 AM

Hi,

 

No OS is installed at this point, correct?

 

1. Try to boot your PC,

2. press Enter immediatly until a menu opens,

3. then press "F10 to diagnose hardware"

4. Edit: Arrow keys to "System information"

5. Arrow Right to "STORAGE"

6. What's on the list?

Reply
Options

10 Posts

08-28-2015

Germany

7 Signins

81 Page Views

  • Posts: 10
  • Registered: ‎08-28-2015
  • Location: Germany
  • Views: 81
  • Message 3 of 10

Re: T450s Windows 7 clean installation fails - driver missing

2015-08-28, 8:56 AM

More or less...

 

I installed Windows 10, which works but I don't like it. Actually I have Ubuntu 15.04 installed, but my goal is to achieve a multiboot system with Windows 7  - for some special Windows Software usecases - and Ubuntu.

 

STORAGE INFORMATION

Manufacturer: Toshiba
Model Number: THNSFJ256GCSU
Serial Number: xxxxxxxxxx
Firmware revision: JULA1102
Size: 238GB
...
...
...

Reply
Options

66 Posts

10-21-2014

Denmark

61 Signins

885 Page Views

  • Posts: 66
  • Registered: ‎10-21-2014
  • Location: Denmark
  • Views: 885
  • Message 4 of 10

Re: T450s Windows 7 clean installation fails - driver missing

2015-08-28, 9:00 AM

Have you tried updating your BIOS?

Reply
Options

10 Posts

08-28-2015

Germany

7 Signins

81 Page Views

  • Posts: 10
  • Registered: ‎08-28-2015
  • Location: Germany
  • Views: 81
  • Message 5 of 10

Re: T450s Windows 7 clean installation fails - driver missing

2015-08-28, 9:11 AM

The Laptop was shipped with the latest Version installed:

 

BIOS Version JBET51WW (1.16)

BIOS Date 2015-07-08

Reply
Options

66 Posts

10-21-2014

Denmark

61 Signins

885 Page Views

  • Posts: 66
  • Registered: ‎10-21-2014
  • Location: Denmark
  • Views: 885
  • Message 6 of 10

Re: T450s Windows 7 clean installation fails - driver missing

2015-08-28, 9:29 AM

Could you post your partition table? Maybe using gparted in Ubuntu? Or disk management in windows.

Reply
Options

12985 Posts

06-06-2011

Russian Federation

17947 Signins

178550 Page Views

  • Posts: 12985
  • Registered: ‎06-06-2011
  • Location: Russian Federation
  • Views: 178550
  • Message 7 of 10

Re: T450s Windows 7 clean installation fails - driver missing

2015-08-28, 17:10 PM
Is win7 iso image ms original or customized?



x220 • Gobi 2000 3g | hdd, msata ssd, wwan, wifi, gps -- unique config
ThinkPad 25 Special Anniversary Edition. #Retro. Signed by D.Hill
T470p | X1 Carbon Gen3 | Miix 2 10" | Yoga Tablet 2-1050F (Android) + BT Keyboard
ThinkPad Stack • 2.4/5 Wireless Router, HDD 1 TB, BT Speaker, Power Bank, Mobile Projector

Do it well, worse becomes itself

Communities:   English    Deutsche    Español    Portugues    Русскоязычное    Česká    Slovenská    Українська   Moto English

Reply
Options

10 Posts

08-28-2015

Germany

7 Signins

81 Page Views

  • Posts: 10
  • Registered: ‎08-28-2015
  • Location: Germany
  • Views: 81
  • Message 8 of 10

Re: T450s Windows 7 clean installation fails - driver missing

2015-08-29, 4:57 AM
#fdisk -l /dev/sda

Disk /dev/sda: 238,5 GiB, 256060514304 bytes, 500118192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 675D94C8-E872-4B8A-86A4-B3117D1A3AED

Device       Start       End   Sectors   Size Type
/dev/sda1     2048   1050623   1048576   512M EFI System
/dev/sda2  1050624   1550335    499712   244M Linux filesystem
/dev/sda3  1550336 500117503 498567168 237,8G Linux filesystem

I know that there is actually no space left on the harddrive to hold an Windows Installation. But thats my acutal problem... The Windows 7 Installer don't recognize any harddrive, because it is lacking the necessary  SATA/AHCI Controller Driver. So I'm unable to delete or create any partition within the Windows installing process.

Reply
Options

10 Posts

08-28-2015

Germany

7 Signins

81 Page Views

  • Posts: 10
  • Registered: ‎08-28-2015
  • Location: Germany
  • Views: 81
  • Message 9 of 10

Re: T450s Windows 7 clean installation fails - driver missing

2015-08-29, 5:02 AM

I've tried both. A "original" USB-Drive Windows 7 SP1 x64 Installation Media - created directly from an official Microsoft DVD. And I included the SATA/AHCI drivers mentioned above in one version. Both fails... Using the default media, because it couldn't find any driver. Using the Version with the inculded driver, the installer shows the driver in the driverlist, but it wasn't able to load the driver due comtability problems...

Reply
Answer
Options

10 Posts

08-28-2015

Germany

7 Signins

81 Page Views

  • Posts: 10
  • Registered: ‎08-28-2015
  • Location: Germany
  • Views: 81
  • Message 10 of 10

Betreff: T450s Windows 7 clean installation fails - driver missing

2015-08-29, 5:25 AM

I've found the solution!

 

Windows 7 isn't cappable of USB 3.0 without any additional drivers, right? So my T450s isn't equippet with USB-2.0 "Only" Ports but with three USB-3.0 Ports. I've changed the USB-3.0 BIOS Feature from it's default "AUTO" setting to enabled. After changig it back to "AUTO" or "DISABLED" the Windows 7 Installer did what he was supposed to... It seems the Installer asked my to install the appropriate USB-3.0 Controller driver and not the SATA/AHCI-Driver.

 

Nevertheless! Thank you for you help!

Cheers!

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All