English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

9 Posts

06-09-2019

NL

9 Signins

41 Page Views

  • Posts: 9
  • Registered: ‎06-09-2019
  • Location: NL
  • Views: 41
  • Message 1 of 15

T460p with Intel HD 530 no HDMI audio

2019-06-10, 0:06 AM

Hi, I have a very strange problem, namely I've recently upgraded from HDD->SSD and installed a fresh copy of Windows 10 Pro, and suddenly I can't change audio output from the speakrs to TV through HDMI. I know the is not a hardware problem because the same thing is working perfectly fine on my Debian. I've installed the latest drivers from Lenovo, checked in Audio setting in Control Panel for hidden disabled devices and still nothing. I've even tried to update to the latest drivers for HD 530 from Intel website but they wouldn't install becuase they are not meant for my system or something (think they have to be signed by Lenovo or sth). Anyone experienced the same problems and have a possible solution? Thank you in advnace!

Reply
Options

1893 Posts

08-02-2018

US

702 Signins

10511 Page Views

  • Posts: 1893
  • Registered: ‎08-02-2018
  • Location: US
  • Views: 10511
  • Message 2 of 15

Re: T460p with Intel HD 530 no HDMI audio

2019-06-10, 20:24 PM

Hi Bukva! Welcome to our forums community. Was there any recent changes made or any updates installed before the issue arise? Try running the update from the Think Vantage app and install all available update.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

9 Posts

06-09-2019

NL

9 Signins

41 Page Views

  • Posts: 9
  • Registered: ‎06-09-2019
  • Location: NL
  • Views: 41
  • Message 3 of 15

Re: T460p with Intel HD 530 no HDMI audio

2019-06-10, 20:29 PM

Hi, the issiue arsied when I've installed a fresh copy of Windows 10, I've tried updating drivers thegouh Think Vinage, and nothing helped. In the mean time I've contacted Microsoft Tech support, one guy suggested downgrading from 1903 to 1809, I've tried that still not working. I really don't know what else to try, the problem is there from the very beggining. Fresh copy of Windows and it's not working.

Reply
Options

1893 Posts

08-02-2018

US

702 Signins

10511 Page Views

  • Posts: 1893
  • Registered: ‎08-02-2018
  • Location: US
  • Views: 10511
  • Message 4 of 15

Re: T460p with Intel HD 530 no HDMI audio

2019-06-10, 21:25 PM

When you open the playback devices, is the TV recognized? If yes, change it to default speaker. Please refer to the sample picture below.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

9 Posts

06-09-2019

NL

9 Signins

41 Page Views

  • Posts: 9
  • Registered: ‎06-09-2019
  • Location: NL
  • Views: 41
  • Message 5 of 15

Re: T460p with Intel HD 530 no HDMI audio

2019-06-10, 21:35 PM
No, that's the point I don't see it there.
Reply
Options

1893 Posts

08-02-2018

US

702 Signins

10511 Page Views

  • Posts: 1893
  • Registered: ‎08-02-2018
  • Location: US
  • Views: 10511
  • Message 6 of 15

Re: T460p with Intel HD 530 no HDMI audio

2019-06-11, 16:11 PM

Uninstall the video graphics driver and audio driver. Try updating the chipset and BIOS manually from the website: https://pcsupport.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-t-series-laptops/thinkpad-t460p/downloads. Disconnect the HDMI cable while installing the driver.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

9 Posts

06-09-2019

NL

9 Signins

41 Page Views

  • Posts: 9
  • Registered: ‎06-09-2019
  • Location: NL
  • Views: 41
  • Message 7 of 15

Re: T460p with Intel HD 530 no HDMI audio

2019-06-11, 16:44 PM

Nope, still the same.

Reply
Options

1893 Posts

08-02-2018

US

702 Signins

10511 Page Views

  • Posts: 1893
  • Registered: ‎08-02-2018
  • Location: US
  • Views: 10511
  • Message 8 of 15

Re: T460p with Intel HD 530 no HDMI audio

2019-06-11, 17:27 PM


Could you try uninstalling and deleting the graphics card driver then reboot. Reinstall from the website then reboot. Check if the issue persist.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

9 Posts

06-09-2019

NL

9 Signins

41 Page Views

  • Posts: 9
  • Registered: ‎06-09-2019
  • Location: NL
  • Views: 41
  • Message 9 of 15

Re: T460p with Intel HD 530 no HDMI audio

2019-06-11, 17:34 PM

That is exactly what I did, and I even disabled wifi so Windows wouldn't install drivers by itself.

Reply
Options

1893 Posts

08-02-2018

US

702 Signins

10511 Page Views

  • Posts: 1893
  • Registered: ‎08-02-2018
  • Location: US
  • Views: 10511
  • Message 10 of 15

Re: T460p with Intel HD 530 no HDMI audio

2019-06-11, 21:14 PM

Try downloading the updated driver(Intel HD 530) directly from Intel's website.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms