English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

2 Posts

07-07-2017

HU

3 Signins

24 Page Views

  • Posts: 2
  • Registered: ‎07-07-2017
  • Location: HU
  • Views: 24
  • Message 1 of 2

T470 Performance issue

2017-07-07, 14:28 PM

Just bought a T470 and it seems like it keeps scaling its performance regardless of the settings in Bios or WIN10, or whatsoever. 

 

Someone could please tell me how to make this laptop perform always at 100%? We are using it for audio applications and these unexpected glitches when CPU is dropping to eg 0.79GHz is just too painful. This laptop seems to have no idea how to handle performance or i just don't know how to set it up properly.

 

thanks!

Reply
Options

17 Posts

11-21-2010

US

23 Signins

222 Page Views

  • Posts: 17
  • Registered: ‎11-21-2010
  • Location: US
  • Views: 222
  • Message 2 of 2

Re: T470 Performance issue

2017-07-09, 2:06 AM

Try this: Go to the control panel, and look for “energy settings”.  Go to the energy plan/setup in use, and click on the “change plan options” link. Go to “advanced energy configuration”, and then go to “CPU energy administer” (the wording for all these might be a bit different), and then increase the minimum frequency (“state”?) of the processor while the computer is plugged in (or running on battery, if willing to have the resulting loss in battery life).

 

Some other things to keep in mind: The i7-7600U has a frequency of 2.8GHz; it can briefly go up as high as 3.9 GHz, but the laws of physics make it not possible to keep the processor at that higher frequency for very long.

 

Also, since we’re mentioning audio and hearing glitches:

 

* A lot of audio interfaces (Focusrite, *cough* *cough*) have issues with audio glitches when the latency has a low value. The solution is to increase the latency; if the latency is too high when the audio does not glitch, then the solution is to get an audio interface with less latency (the $80 Behringer UMC-204HD has somewhat noisy preamps, but has really good low latency Windows drivers)

* To reduce the CPU load of a big DAW project, make sure that any effects are “frozen” or printed to a separate track. One CPU hog is placing a different reverb on every track; it’s probably better to instead have one or two reverbs on the bus instead. Here’s a more in depth discussion: https://valhalladsp.com/2017/04/21/sending-heart-snare-reverb/

* Another trick, if the DAW project has more than 24 tracks or so, is to submix tracks so that less tracks are running at the same time.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete