cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
WillBot
Paper Tape
Posts: 1
Registered: ‎09-17-2019
Location: US
Views: 408
Message 1 of 4

T470 Thunderbolt Firmware Error

When installing the thunderbolt firmware update utility I receive the following error:

 

"No active Thunderbolt(TM) controller found in the system or Thunderbolt software is not present in the system. Make sure you have Thunderbolt software installed. Then connet Thunderbolt device and press OK to retry or cancel to abort firmware update process."

 

I have the software installed. And the thunderbolt port doesn't give power to my TB16 dock (no light when plugging the cable in unlike on my dell precision work laptop).

Support Specialist
Posts: 743
Registered: ‎04-23-2019
Location: US
Views: 325
Message 2 of 4

Re: T470 Thunderbolt Firmware Error

Hi WillBot.

Welcome to the Community Forums!

We would like to clarify how you are trying to update the Firmware for the TB? Are you using an update tool (Vantage) or are you downloading it directly from the support website (https://pcsupport.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-t-series-laptops/thinkpad-...)?

Let us know. We'll wait for your update.

Regards.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

TobiasKr
What's DOS?
Posts: 1
Registered: ‎10-04-2019
Location: DK
Views: 268
Message 3 of 4

Re: T470 Thunderbolt Firmware Error

While I didn't create the original post, I am getting a similar error - among other.

I have tried updating through the link you have referenced, both manually, as well as using Lenovo Service Bridge to identify my needed updates. I have also used Lenovo Vantage and system updates.

It is not the first time I have experienced some issues with Thunderbolt devices/TB controller not working from one day to the other, but until now, I've always been able to fix it by flashing using the Thunderbolt Firmware Update (https://download.lenovo.com/pccbbs/mobiles/n1qth07w.exe), but now I'm no longer on Windows version 1809 - if I remember correctly, its now version 1903, and thus, the firmware update no longer seems to do the trick. I feel like I've tried every trick in the book: Numerous windows resets followed by Lenovo Vantage updates, automatic updates through lenovo service bridge and so forth (one by one, separate resets as it doesn't seem to do the trick).

Thanks a bunch!
robynasi1
Paper Tape
Posts: 5
Registered: ‎10-27-2019
Location: IT
Views: 157
Message 4 of 4

Re: T470 Thunderbolt Firmware Error

Hi! I'm having the same issue, with a T570. I was using a external GPU and sometimes I had to reinstall the TB3 firmware. Now my eGPU can't be recognized... please help.

And we're back...

Move delayed but still coming

Learn More

Check out current deals!


Shop current deals

Top Kudoed Authors