cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
anom3
Paper Tape
Posts: 6
Registered: ‎11-17-2017
Location: PL
Views: 353
Message 1 of 3

T470 + Windows 7 + NVME (Toshiba) = Inconsistent write performance

I own a T470 with a Lenovo branded 256GB NVME drive, running Windows 7.

 

The drive is thnSn5256gpuk according to device manager.

 

Looks like this is a rebranded OCZ XG3/4 drive.

 

---

 

I am getting fairly inconsistent write performance on this drive.

 

According to both crystaldiskmark and as benchmarks, the write performance will sometimes be 700mb/s, other times 300mb/s.

 

I can run the test once, it will show up 700mb/s, run again, and it will be 300mb/s.

 

---

 

I have tried switching over to the ocz nvme windows 7 drivers, which work just fine btw. But to no avail, microsoft nvme drivers or the ocz ones, both have the same symptoms.

 

---

 

Anyone able to get consistent write performance from this setup?

 

---

 

NOTE:

 

Please don't sudgest upgrading my bios, flashing the newest firmware on the ssd or making sure write cache is enabled in device manager... Or any of the low hanging fruit... I've spent about 5 hours trying to get proper (as per the spec of the drive, from the toshiba site) write performance on this drive.

anom3
Paper Tape
Posts: 6
Registered: ‎11-17-2017
Location: PL
Views: 290
Message 2 of 3

Re: T470 + Windows 7 + NVME (Toshiba) = Inconsistent write performance

So I have been able to resolve this. Although the solution is not the best.

 

I decided to buy a Samsung 960 EVO SSD and replace the Toshiba in the T470. All the reviews online say the samsung drives are the best, and rightfully so.

 

Once I replaced the drive and restored by windows from a backup to the drive, I am now getting correct write performance from the drive. I installed the latest correct samsung nvme drivers and updated the firmware on the drive as well.

 

I understand the T470 is using a PCIe x2 (NOT x4) bus for the NVME, so getting the max speced performance from the NVME is not possisble... But its alot closer now.

 

I get about the same reads (1400mb/s) and the writes are now stable at 1100-1200mb/s.

 

So to summarize, either the Toshiba drives that Lenovo included are not the best or the Windows 7 drivers are not very mature. Samsung has fairly mature Windows 7 drivers, so if anyone is hoping on squeezing the most performance out of their T470 I recommend the upgrade.

 

I paid about 150USD for the drive, I should be able to get about half that back for selling the Toshiba used... So the cost was not THAT bad.

 

PS : The laptop was fast to start with, but there is a noticable performance improvment now. Simply put, when I log in via fingerprint (fingerprint at the bios prompt that is), since it auto logs into Windows now, I hear both windows start sounds at the SAME TIME now. The "windows has loaded" chime and the "you have logged in" sound.

Highlighted
anom3
Paper Tape
Posts: 6
Registered: ‎11-17-2017
Location: PL
Views: 286
Message 3 of 3

Re: T470 + Windows 7 + NVME (Toshiba) = Inconsistent write performance

Here is the kind of performance I am seeing on the drive now. Nowhere near the max this drive can do, but thats because of Lenovos choice to go PCIe x2 rather then x4. Still, I am happy with this.

 

Untitled.png

Check out current deals!


Shop current deals

Top Kudoed Authors