English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

2 Posts

05-15-2018

IT

5 Signins

19 Page Views

  • Posts: 2
  • Registered: ‎05-15-2018
  • Location: IT
  • Views: 19
  • Message 1 of 2

T470 internal battery not recognized but working

2018-05-15, 18:09 PM

Hello!
I have a Thinkpad T470 that came originally without the internal battery, having in its place a dummy. So my computer used to show only one battery (the external one).

I recently decided to install an internal battery as well. The problem is that my laptop doesn't seem to recognise it completely: it shows two batteries, but the internal one is "unrecognized" and always showing 0% charge, both under Windows and Debian. Nonetheless, it works: I tried booting up the laptop after unplugging it and removing the external battery, and everything went just fine. Bios and every other Lenovo-related software is up to date. Has somebody else experienced the same problem? Do you have any idea as to what may be causing this?

 

Reply
Options

1 Posts

08-03-2019

US

1 Signins

11 Page Views

  • Posts: 1
  • Registered: ‎08-03-2019
  • Location: US
  • Views: 11
  • Message 2 of 2

Re: T470 internal battery not recognized but working

2019-08-03, 22:00 PM

Same exact issue except mine shows Battery 1: Not Present

 

Even after I take out the removable battery the system will boot up and Windows 10 (1903) will show a red x. 

 

The only thing I haven't tried to do is reseeding this. 

 

Also how are you charging your laptop?  I noticed that this problem started happening only after I used a Type C/Thunderbolt port to charge the laptop.  

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete