English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

3 Posts

06-23-2019

US

1 Signins

33 Page Views

  • Posts: 3
  • Registered: ‎06-23-2019
  • Location: US
  • Views: 33
  • Message 1 of 3

T470 no power after RAM install

2019-06-23, 16:50 PM

Hi,

I have Thinkpad T470 I've been using for 1.5 years. I installed new SSD a year ago and didn't have any issues. Today I tried to install one more memory into an empty slot. I disabled internal battery in BIOS, turned it off, dissembled and put a new memory in. But after that the laptop doesn't start up. Power green button doesn't blink. Tried to remove that added memory - no luck. Tried to reset CMOS - no luck. What else can I do? I think it's still under warranty but I'd like to try everything myself before that. No sure how fast support is in Lenovo though. Thanks

Reply
Options

632 Posts

12-30-2017

PL

1418 Signins

16129 Page Views

  • Posts: 632
  • Registered: ‎12-30-2017
  • Location: PL
  • Views: 16129
  • Message 2 of 3

Re: T470 no power after RAM install

2019-06-23, 16:57 PM

Have you tried to connect AC power adapter and then power it on?

------
...
Reply
Options

3 Posts

06-23-2019

US

1 Signins

33 Page Views

  • Posts: 3
  • Registered: ‎06-23-2019
  • Location: US
  • Views: 33
  • Message 3 of 3

Re: T470 no power after RAM install

2019-06-23, 17:06 PM
yeah I've tried that and didn't help :(
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete