English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

3 Posts

12-26-2019

US

5 Signins

48 Page Views

  • Posts: 3
  • Registered: ‎12-26-2019
  • Location: US
  • Views: 48
  • Message 1 of 6

T470S Battery 1 won't charge, Battery 2 at 7% only, Power Control says batteries in good health?

2019-12-26, 5:04 AM

T470S with Windows 7, this is the 3rd year in use. Most of the time it has power adapter plugged in. I set the Battery Charge Mode to "Optimize for battery life", it normally charges up to 75% then stop. 

 

Two days ago something strange happened: first I noticed that it charged to 49% then stop, then couple of hours later it's 17%. I just thought there's no way that both batteries could deteriorate so fast, it must be the battery gauge. So I clicked the "Perfrom Reset" button to reset the battery gauge, and let it run its full course over night. 

 

This morning when I check it, it's only 4% left. Needless to say if I un-plug the power cord, it will shut down instantly. But when I opened the "Lenovo Power Control", and view the status of battery, to my surprise, it says condition of both batteries are "Good" :smileymad: and gives me a green icon. But it does show that battery 1 (the 21.2Wh one) is 0% remaining, and battery 2 (the 19.73Wh one) is 7% remaining.

 

Seems that battery 1 is completely drained, and won't charge, and battery 2 is barely charging, but the question is: why the Power Control still shows Condition Good? How to tell if the battery is really dead or not, besides using the Lenovo Power Control?

 

I changed the battery charging mode to "Always Fully Charge", and waited for half an hour, no, magic didn't happen, it's still 4%.

 

Anybody has similiar experience? Any advice is appreciated!

Reply
Options

293 Posts

11-26-2019

HK

124 Signins

2553 Page Views

  • Posts: 293
  • Registered: ‎11-26-2019
  • Location: HK
  • Views: 2553
  • Message 2 of 6

Re: T470S Battery 1 won't charge, Battery 2 at 7% only, Power Control says batteries in good health?

2019-12-27, 2:38 AM
Try to remove the lid and have a look the batteries. Or contact the technical support if you are not feeling comfortable to do it yourself.
Reply
Options

3 Posts

12-26-2019

US

5 Signins

48 Page Views

  • Posts: 3
  • Registered: ‎12-26-2019
  • Location: US
  • Views: 48
  • Message 3 of 6

Re: T470S Battery 1 won't charge, Battery 2 at 7% only, Power Control says batteries in good health?

2019-12-30, 15:46 PM

I took out both batteries and don't see anything unusual. I put back the secondary battery, and reboot with power plugged in, and it start to recharge right away, all the way to 75%, as if nothing happened. :smileyindifferent:

 

So I removed the secondary battery, and put back the main battery, and reboot with power plugged in, it start to recharge as well! Now I'm running with both batteries , and they are all well again. Tried all kinds of power-test, gauge reset, they all went well.

 

I still have no clue what's going on -- could it be a loose connection, battery disconnected? That seems impossible to me since the battery connection part is very firmly touch and taped, it took me some effort to detach it. 

 

Clueless.... much ado about nothing... but at least it's running good now, until next time. 

 

Thanks for your advice anyway. Happy new year!

 

 

Reply
Options

293 Posts

11-26-2019

HK

124 Signins

2553 Page Views

  • Posts: 293
  • Registered: ‎11-26-2019
  • Location: HK
  • Views: 2553
  • Message 4 of 6

Re: T470S Battery 1 won't charge, Battery 2 at 7% only, Power Control says batteries in good health?

2019-12-31, 0:34 AM
Welcome to the world of IT. Some times you will encounter some "Don't ask how. It works!!" moment
Reply
Options

5 Posts

12-21-2019

RS

3 Signins

27 Page Views

  • Posts: 5
  • Registered: ‎12-21-2019
  • Location: RS
  • Views: 27
  • Message 5 of 6

Re: T470S Battery 1 won't charge, Battery 2 at 7% only, Power Control says batteries in good health?

2020-01-02, 15:59 PM

I have a similar problem. Everything looks ok but when my t470s is on a battery it starts to rapidly show: 5h34minutes...after 10min shows: 3h13minutes.... after 20minutes I have only 1h20minutes left and when a first battery is near 5% ugly lenovo shuts itself down.

 

This IS a serious problem for this kind of equipment but it looks nobody in lenovo company care about that.

 

Of course, there are OTHER players on a market.

Reply
Options

4775 Posts

04-25-2008

US

39293 Signins

739649 Page Views

  • Posts: 4775
  • Registered: ‎04-25-2008
  • Location: US
  • Views: 739649
  • Message 6 of 6

Re: T470S Battery 1 won't charge, Battery 2 at 7% only, Power Control says batteries in good health?

2020-01-02, 23:21 PM

, please don't start new multiple threads when this one already exists. It makes the discussion impossible to follow. Thanks!

I don't work for Lenovo. I'm a crazy volunteer!
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save