cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Jpewterbaugh
Ctrl-Alt-Del
Posts: 18
Registered: ‎10-25-2016
Location: US
Views: 3,849
Message 1 of 13

T470S auto wireless disconnection

Is anyone else using the new T470S BIOS feature, auto wireless disconnection? It works great most of the time but periodically when you undock it will not re-enable the wireless. We have to re-dock or restart to fix. I have sent an e-mail to our TAM but wanted to reach out to the community as well.

Lenovo Staff
Lenovo Staff
Posts: 6,042
Registered: ‎10-29-2009
Location: NC
Views: 3,797
Message 2 of 13

Re: T470S auto wireless disconnection

Can you please tell me BIOS version on your T470s?

Also, what dock are you using? 

Jpewterbaugh
Ctrl-Alt-Del
Posts: 18
Registered: ‎10-25-2016
Location: US
Views: 3,793
Message 3 of 13

Re: T470S auto wireless disconnection

BIOS version 1.11, released on 6/6/2017.

ThinkPad Pro Dock

Lenovo Staff
Lenovo Staff
Posts: 6,042
Registered: ‎10-29-2009
Location: NC
Views: 3,791
Message 4 of 13

Re: T470S auto wireless disconnection

OK, I will try to reproduce the problem here.

Can you please tell me exactly how you are undocking the PC when the problem happens?  For example, is the lid open?  Is the PC sleeping or turned on?  Does this detail matter?

Also, what is the failure rate?  For example, does it happen in 1 out of 10 undocks?

Jpewterbaugh
Ctrl-Alt-Del
Posts: 18
Registered: ‎10-25-2016
Location: US
Views: 3,788
Message 5 of 13

Re: T470S auto wireless disconnection

We were specifically testing with the lid open while docked yesterday. Laptop was turned on. The failure rate is probably close to 65%, doesn't happen everytime but happens enough for us to reproduce. One thing to note is that we weren't able to reproduce this with just an ethernet cable, it only seems to happen with a dock.

I can give you more specifics once I'm back in the office on Monday.

Lenovo Staff
Lenovo Staff
Posts: 6,042
Registered: ‎10-29-2009
Location: NC
Views: 3,782
Message 6 of 13

Re: T470S auto wireless disconnection

I tried ~20 times here, undocking the system, and wifi turned on every time.  So I appreciate any specific tips you have to reproduce the problem here.  It might also have to do with the specific WiFi adapter in your system, so please give me the details about that as well.  e.g. is it Intel 8265 or something else?

Jpewterbaugh
Ctrl-Alt-Del
Posts: 18
Registered: ‎10-25-2016
Location: US
Views: 3,611
Message 7 of 13

Re: T470S auto wireless disconnection

I apologize for the delay in responding. My tech did some testing with the newest BIOS update (v1.13) and can no longer re-create the problem.

Guru
Posts: 1,680
Registered: ‎07-21-2010
Location: US
Views: 2,659
Message 8 of 13

Re: T470S auto wireless disconnection

I think i have a similiar issue except not with dock.  I posted a question a while back but no one responded.  The moment i enable this feature i am not able to enable wireless unless i plug in a ethernet cable first.  Does that happen to you too?

 


 If a post answers your question, please mark it as an”Accepted Solution“!
 If a post helps you, please click the star to give it a "Kudo"!


 I do not work for, nor do I speak for Lenovo. I will not respond to unsolicited private messages. Questions belong in the forum so it may   help other forum members as well.
 T490, TP 25 Retro, X1 Yoga 3rd Gen, W510 850 EVO, A30p
 Retired 385D, A20p, A21p

Lenovo Staff
Lenovo Staff
Posts: 6,042
Registered: ‎10-29-2009
Location: NC
Views: 2,654
Message 9 of 13

Re: T470S auto wireless disconnection

green5178

 

I know there was a BIOS bug in the past, where it was implemented backwards (e.g. wireless off when ethernet disconnected).  I believe this was already fixed.  What BIOS version is on your PC?  You can get this information by running msinfo32 and looking for "BIOS Version/Date" in the list on the right.

Guru
Posts: 1,680
Registered: ‎07-21-2010
Location: US
Views: 2,650
Message 10 of 13

Re: T470S auto wireless disconnection

I am running Bios 1.43.  It was true on 1.42 also see my previous post.  Someone else on X270 has same issue too.

 

https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/auto-disconnect-wireless-issues/td-p/386...

 


 If a post answers your question, please mark it as an”Accepted Solution“!
 If a post helps you, please click the star to give it a "Kudo"!


 I do not work for, nor do I speak for Lenovo. I will not respond to unsolicited private messages. Questions belong in the forum so it may   help other forum members as well.
 T490, TP 25 Retro, X1 Yoga 3rd Gen, W510 850 EVO, A30p
 Retired 385D, A20p, A21p

Check out current deals!


Shop current deals

Top Kudoed Authors