cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
T470s_user
Paper Tape
Posts: 1
Registered: ‎07-06-2017
Location: US
Views: 1,870
Message 1 of 1

T470s + Anker USB-C to HDMI = 4K @ 60 Hz

Hi everyone,

 

As you may know the HDMI output on T470s supports 4K resolution at only 30 Hz. This makes mouse mouse movements quite choppy and at least for me frustrating. To use a higher refresh rate we have to use some kind of a USB-C to HDMI or DisplayPort adapter. 

 

Here I'm posting a solution how to get 4K working at 60 Hz using Anker Aluminium USB C Type C to HDMI Converter, running on Windows 10. By default the Anker USB-C to HDMI converter on this laptop goes up to 4K (3840x2160) at only 30 Hz and it's not possible to increase the refresh rate any higher. To squeeze 60 Hz out of it you need to do a bit of work. Smiley Happy

 

The solution:

- right click anywhere on your Desktop and select Intel Graphics Settings

- click on Display

- click on Custom Resolutions and select "Yes" when presented with the warning

- make sure that in the drop down menu, in lower left corner of the window, you select your 4K external monitor, not the laptop's main screen

- type 3840 for Width, 2160 for Height and 60 for Refresh Rate

- the important part: you need to select some other Timing Standard from the drop down menu and not the default "GTF". Because if you select "GTF" the application will tell you that the custom resolution exceeds the bandwidth limitaions and it will not allow you to add it. I used the "CEA 861" Timing Standard in my case. Perhaps other timing standards my also work, it may depend on your monitor, I'm not sure. My monitor is LG 27UD68P.

- click on the Add button in the lower right corner to add the custom resolution

 

Now let's switch to the newly added custom resolution / refresh rate:

- open Display settings in Windows 10

- select your external 4K monitor and click on Advanced display settings

- click Display adapter properties

- click on the Monitor tab

- here you may need to uncheck the "Hide moes that this monitor cannot display" checkbox

- select 60 Hz from the drop down menu and click Apply

- the important part: after clicking Apply I had to disconnect the HDMI cable from the Anker adapter and plug it back in (I did this fairly quickly in ~3 seconds) so that the monitor started working at 60 Hz and I was able to click "Keep changes". If I left the cable in, the screen went dark and the settings automatically reverted back to 30 Hz after 15 seconds. So at least in my case I had to temporarily unplug the HDMI cable and plug it back it.

 

That's it. Your external 4K monitor should now work at buttery smooth 60 Hz. Smiley Happy

Check out current deals!


Shop current deals

Top Kudoed Authors