English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

2 Posts

12-17-2018

US

3 Signins

42 Page Views

  • Posts: 2
  • Registered: ‎12-17-2018
  • Location: US
  • Views: 42
  • Message 1 of 2

T480 Using a mechanical dock. No usb after all firmware updates and drivers.

2018-12-17, 15:46 PM

Hi I cant seem to locate a fix for my lenovo t480. I cannot get any usb ports to register through the dock. I have tried reinstalling usb drivers through device manger, updating dock firmware, updating all lenovo system drivers , changing power adaptor through the dock and re seating it multiple times. I have other t480's that work on this dock. The usb's work fine on the actual laptop just not the dock. Any help would be apreciated. Thank you!

Reply
Options

222 Posts

08-02-2018

PH

155 Signins

855 Page Views

  • Posts: 222
  • Registered: ‎08-02-2018
  • Location: PH
  • Views: 855
  • Message 2 of 2

Re: T480 Using a mechanical dock. No usb after all firmware updates and drivers.

2019-01-30, 14:10 PM

Hi OmenJoi! Thanks for posting in our community. Were there any updates or software upgrade install prior to this case? Have you already tried to use the mechanical dock on another laptop? Let us try that first for us to isolate the issue since you have tried other troubleshooting steps.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete