English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

1 Posts

12-17-2019

US

1 Signins

45 Page Views

  • Posts: 1
  • Registered: ‎12-17-2019
  • Location: US
  • Views: 45
  • Message 1 of 1

T480 display dims and loses ethernet connection when battery reaches 100%

2019-12-17, 17:03 PM

Hi all,

 

I have an issue with a T480s laptop once battery reaches 100% charge.

 

When the laptop reaches full charge, the display on the T480 will automatically dim and lose ethernet connection momentarily.

 

This can occur either when the computer is docked (ThinkPad USB-C) or connected to the 65Watt travel charger.

 

It does not do this when it is 99% and below, strictly 100% and a few moments after it reaches it. Current work-around is to plug in the laptop charger once its low and disconnect once it hits somewhere in the 90's.

 

If the laptop is docked, and battery is 100%, it will disconnect from LAN and auto-connect to WLAN (it is setup that way). In the case of strictly using the travel charger and working via WLAN, it will disconnect and would lose internet connection entirely.

 

I've done the troubleshooting steps mentioned below and still having the same issues.

 

Troubleshooting:

  • Installed all pending Lenovo & Windows updates
    • included BIOS, ThunderBolt Firmware, Power Management
  • Modified power settings to not go into sleep mode when plugged into power
  • Removed "turn off this adapter to save power" for both LAN and WLAN adapters
  • Completed the "battery pin hole reset" from the bottom side of the laptop.
  • Changed source of power

 

Any ideas?

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete