English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

3 Posts

05-14-2019

RO

3 Signins

41 Page Views

  • Posts: 3
  • Registered: ‎05-14-2019
  • Location: RO
  • Views: 41
  • Message 1 of 5

T480 doesn't boot/hangs while dock is attached via USB-C

2019-05-14, 14:02 PM

T480 doesn't boot while dock is attached via USB-C

Both laptop and USB-C dock station has the latest BIOS/Firmware

 

If I boot the laptop without docking attached, laptop boots normally, otherwise is hanging on Lenovo prompt to press key in order to interrupt normal startup, laptop's keyboard seems unrenspossive.

 

Docking works OK after Windows OS start loading

Solved! See the solution
Reply
Options

6018 Posts

10-29-2009

NC

17489 Signins

156053 Page Views

  • Posts: 6018
  • Registered: ‎10-29-2009
  • Location: NC
  • Views: 156053
  • Message 2 of 5

Re: T480 doesn't boot/hangs while dock is attached via USB-C

2019-05-15, 13:20 PM

What devices are connected to the dock?  If you unplug everything from dock, is problem gone?

Reply
Options

3 Posts

05-14-2019

RO

3 Signins

41 Page Views

  • Posts: 3
  • Registered: ‎05-14-2019
  • Location: RO
  • Views: 41
  • Message 3 of 5

Re: T480 doesn't boot/hangs while dock is attached via USB-C

2019-05-15, 15:17 PM
Several (Monitors, Handset, Keyboard/Mouse, Network, etc.), but I identified to be one of the device which is not recognized by Windows, seems when unrecognized device is attached the Laptop simply hangs during BIOS/UEFI preload.

As an workaround I've changed the device to powered USB and seems to bypass this limitation.
Reply
Options

1 Posts

05-21-2019

US

1 Signins

25 Page Views

  • Posts: 1
  • Registered: ‎05-21-2019
  • Location: US
  • Views: 25
  • Message 4 of 5

Re: T480 doesn't boot/hangs while dock is attached via USB-C

2019-05-21, 16:26 PM

I have the same problem. I have many things connect too. Dual monitors, headset, network and wireless keyboard and mouse. When I pull it off the dock it boots normally. Any suggestions? 

Reply
Options

3 Posts

05-14-2019

RO

3 Signins

41 Page Views

  • Posts: 3
  • Registered: ‎05-14-2019
  • Location: RO
  • Views: 41
  • Message 5 of 5

Re: T480 doesn't boot/hangs while dock is attached via USB-C

2019-05-21, 16:44 PM

First see if laptop boots normaly if there is no device connected on dock, then try booting connecting 1 device at a time until you find the culprit one. When you have multiple devices connected allow at least 10sec for preeboot to initialize.

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save