English Community

ThinkPad NotebooksThinkPad: T400 / T500 and newer T series Laptops
All Forum Topics
Options

7 Posts

06-08-2018

DE

13 Signins

248 Page Views

  • Posts: 7
  • Registered: ‎06-08-2018
  • Location: DE
  • Views: 248
  • Message 1 of 2

T480s with Thunderbolt Dock and frequent, random crashing

2019-10-22, 15:21 PM

Hi,


I have been using the T480s for around 1.5 years now. The first OS I ran on it was Windows 10. I ran into serious issues as described in a previous post. This post extends a recent previous post from the Ubuntu sub-forum; however, as detailed below, I now think this is an OS-independent problem.

These issues kind of subsided (alas, other users still report active, similar issues) for me. Still, after a year or so of running the laptop with Win10 on it, much more serious issues occurred in the form of very random BSODs, with the error code whea_uncorrectable_error.
This indicates faulty hardware, or firmware/drivers (?).
The issue persisted so strongly that it would occur on an entirely fresh Win10 install with a fully wiped SSD (the laptop's only SSD/storage), after even interfering with the Windows reparation/restoration process itself.

It made me switch to Ubuntu as the most beginner-friendly Linux distribution. And sure enough, it worked better.

Still, there is significant trouble in the form of random crashes:

1. I cannot run the dedicated GPU (nVidia MX150, using nvidia-driver-418), it will freeze the system fully and eventually reboot the machine automatically. Except for REISUB, the system remains unresponsive.
Using the built-in GPU (Intel UHD Graphics 620 from the i7-8550U CPU) is a tough pill to swallow; it gives strong tearing (horizontal artifacts) in full-screen videos (tested in offline VLC videos [downloaded from https://www.youtube.com/watch?v=9hIRq5HTh5s] as well as Firefox YouTube/Netflix/Amazon) that makes watching full-screen impossible.

2. Whenever I unplug the laptop from the Thunderbolt dock and replug it, I can expect one random crash after around half an hour of using the machine. Once this crash has occurred, the machine runs normal again, indefinitely until plugged out and in again. As with the crash when using the nVidia card, this crash is felt by a total system freeze, where only REISUB remains responsive (which doesn't get me far). In essence, I do not dare unplug the laptop any more, because it will lead to a very unstable system afterwards.

3. Plugging in RJ45 LAN leads to freezes and complete crashes, too. I had bought an RJ45-to-USB3 adapter, so that the network cable is not directly plugged into the dock. This works.

4. The kernel was recently upgraded through Canonical's Software Updater, from 5.0.0-31-generic to 5.0.0-32-generic. And sure enough, my laptop would no longer boot. Only by booting into 5.0.0-31 recovery mode (then choosing to resume a regular boot) was I able to get into the system. Afterwards, I was able to also boot into 5.0.0-32 normally. Before, it would hang in the loading screen after the hard disk password prompt. After hanging for a while, it would reboot; rinse and repeat until action was taken by booting into the old kernel.
In an attempt to boot into 5.0.0-32 (new kernel) in recovery mode, I received this error message:

 

HqDXanx.jpg

 

The BIOS is on the latest version (1.34). Now I wonder if my laptop is a warranty case? Especially in conjunction with the Win10 issues earlier this year, I now have two wholly different operating systems crashing and complaining about faulty, uncorrectable hardware errors.

I have never dropped, gotten wet or otherwise damaged the machine.


Sadly, the process to open warranty support tickets leads me to https://www.managedtechnicalsupportaccess.com/mtsarva/lenovo.html, the worst website I have seen in a long time. The process fails when it prompts me to put in a language (next to serial number etc.), but its dropdown menu doesn't offer languages, just "--- Select One ---", which the form doesn't accept as a valid input.

So if this post were to be boiled down to a question, it would probably be: is this behaviour normal? I expected issues with the nVidia graphics and being 'on my own' in Linux, but the latest kernel booting issues seem to be much deeper (the errors hints at the CPU) and in line with previous errors of the Windows OS.

My current screenfetch stats are:

OS: Ubuntu 19.04 disco
Kernel: x86_64 Linux 5.0.0-32-generic
Uptime: 44m
Packages: 2943
Shell: bash 5.0.3
Resolution: 5120x1440
DE: GNOME
WM: GNOME Shell
WM Theme:
GTK Theme: Yaru-dark [GTK2/3]
Icon Theme: Yaru
Font: Ubuntu 11
CPU: Intel Core i7-8550U @ 8x 4GHz [50.0°C]
GPU: intel
RAM: 2820MiB / 15932MiB

The Thunderbolt dock has been replaced already, which did not seem to have solved anything. Attached to the dock are:

- Sabaj A4 Amplifier via Front-USB
- G203 Mouse via USB on the back
- Ducky One 2 keyboard via USB on the back
- DELL 2715H monitor via DisplayPort (had it on HDMI before, didn't change anything)
- RJ45-to-USB3 adapter via the USB on the back.

 

All quite standard and non-demanding stuff I hope. The RJ45 adapter is explained above.

 

I had imagined a different distro might do the trick, one with a rolling release and the very latest updates (perhaps Manjaro?). But seeing how this kernel update was not a succes, I should hold back.

 

The "Full (Unattended)" Hardware Diagnostic program gave the final result code U154JK34S-86GU2F. The full log can be found here: https://pastebin.com/R8wibGEa

 

The result screen looks like:

 

All tests pass. But clearly, not all is well still.

 

Thank you very much for reading.

Solved! See the solution
Reply
Options

7 Posts

06-08-2018

DE

13 Signins

248 Page Views

  • Posts: 7
  • Registered: ‎06-08-2018
  • Location: DE
  • Views: 248
  • Message 2 of 2

Re: T480s with Thunderbolt Dock and frequent, random crashing

2019-10-30, 8:26 AM
This indeed seemed to have been a broken machine. I handed it in for warranty. All they could test for is a switch of the hard drive, since all other components are fixed onto the motherboard (I did not know this).

So they switched the SSD, got the same error (fresh Windows 10 install ending in 'whea_uncorrectable_error' before login screen; they did not support Ubuntu, so I had to install Windows before handing it in). As a consequence, all that was left was to exchange the motherboard. Therefore, they weren't able to tell me what component exactly went wrong. Could have been anything but the SSD, my bet is memory.

Now, the machine seems to be working fine (apart of course from the tiring old issues with the Thunderbolt 3 dock and dual-GPU w/ nVidia).

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save