cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
ppGrande
Fanfold Paper
Posts: 12
Registered: ‎04-19-2011
Location: Spain
Views: 406
Message 1 of 6

T500 Batteries DEAD even in Good health

I have two batteries for my T500, both 6 cells, and both in good health acording the lenovo power manager

 

but, the cruel reality, is that they do not last more than 10 minutes, they suddenly jump from 75 or 80 % to a minimum of 5 - 10% of power, and couple of minutes later makes my pc powerless. Even charging give a funny measures, estay for long time in loger percentages, and then it goes upp fast and reach 99/100.

 

They both have like 2 years, I have been using them alternativelly, one have 246 cicles, the other 211, capacity of 39.31 (out of 56.18) and 41,15 (out of 56.18 too) 

 

I know they are wear out to some extend, but shouldn't they last a little MUCH longer?

Come'on, they are original Lenovo (manufactured by Sony) batteries.

Is anything I can do beside buying new ones?

 

 

 

 

lead_org Microsoft MVP Contributor
Microsoft MVP Contributor
Posts: 21,009
Registered: ‎12-19-2008
Location: Australia, Melbourne
Views: 389
Message 2 of 6

Re: T500 Batteries DEAD even in Good health

you can try a battery reset, but i don't think that would help very much.

Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
ppGrande
Fanfold Paper
Posts: 12
Registered: ‎04-19-2011
Location: Spain
Views: 384
Message 3 of 6

Re: T500 Batteries DEAD even in Good health

Indeed I did it,

and as you think, it didn't help.

 

Is that normal, that after two years * half time, +200 cicles, baterries are to be replace, even the power manager says "good health"?

(I wonder what's for power manager...) 

lead_org Microsoft MVP Contributor
Microsoft MVP Contributor
Posts: 21,009
Registered: ‎12-19-2008
Location: Australia, Melbourne
Views: 380
Message 4 of 6

Re: T500 Batteries DEAD even in Good health

For a Sony battery, this behaviour was quite common. I have couple of Sony and Sanyo celled battery in the T500 failing at 100 odd cycles with around 2 to 2.5 years since their first use.

Regards,

Jin Li

May this year, be the year of 'DO'!

I am a volunteer, and not a paid staff of Lenovo or Microsoft
ppGrande
Fanfold Paper
Posts: 12
Registered: ‎04-19-2011
Location: Spain
Views: 358
Message 5 of 6

Re: T500 Batteries DEAD even in Good health

thanks for the info, quite clear

so, new batteries, damm

thanks sony ...

Guru
Posts: 948
Registered: ‎06-03-2011
Location: US
Views: 328
Message 6 of 6

Re: T500 Batteries DEAD even in Good health

Be happy you got that much use out of them! My first T400 battery only lasted for about 18 months.

X1 Carbon 3rd Gen Type 20BT i7-5500U, 2560x1440 (non-touch), Win 10 Pro, 8GB RAM, 512 SSD, Intel 7625 WiFi, BT 4.0 | ThinkVision P24q-10 monitor

------------------------------------------
When asking for help, post your question in the forum. Remember to include your system type, model number, and OS. Do not post your serial number.

Did someone help you today? Thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help others with the same question in the future.

Check out current deals!


Shop current deals

Top Kudoed Authors