cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
bluedog925
Fanfold Paper
Posts: 3
Registered: ‎10-22-2010
Location: San Ramon, CA
Views: 2,439
Message 1 of 7

T510 WIFI connection periodically stops working even though status is connected

I have a T510 running Windows 7 64-bit w/ Centrino Ultimate-N 6300 AGN.  My system is connected to a Netgear 802.11n network, configured for WPA-2.  (I haven't asked the specifics about the router model number and configuration).

 

My laptop initially connects to the wireless network fine: browser, email, etc. work perfectly; however, after 20-40 minutes the connection always suddenly stops working.  The status always remains "CONNECTED" but I cannot seem to access the Internet.  I can disconnect and reconnect to get it working 100% of the time, but it's getting annoying if I do this 10+ times per day.  

 

Based on various suggestions on various boards, I tried uninstalling ThinkAccess Connections; I turned off WIFI power savings; I installed the latest Intel WIFI drivers today, but nothing has solved this problem.  I saw one board that mentioned a similar problem related to a "Zone Alarm Free Firewall" but I didn't follow that procedure because I didn't have success with other fixes and I didn't want to mess with any internal firewall stuff unless I had a high confidence it would work.

 

I would really appreciate any insights into this.  None of my co-workers have this problem, and I also connected with my ThinkPad R61 and had no problems getting disconnected.

 

Thanks!

Guru
Posts: 9,598
Registered: ‎12-26-2009
Location: CA
Views: 2,413
Message 2 of 7

Re: T510 WIFI connection periodically stops working even though status is connected

WHen it does fail, try doing the following in Command Prompt:
ipconfig /flushdns
ipconfig /registerdns

See if that fixes it.

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
bluedog925
Fanfold Paper
Posts: 3
Registered: ‎10-22-2010
Location: San Ramon, CA
Views: 2,370
Message 3 of 7

Re: T510 WIFI connection periodically stops working even though status is connected

Thanks for the suggestion!  I will definitely give that a try on Monday when I'm in the office.  And I'd be happy to provide input to your research.

 

Thanks again!

bluedog925
Fanfold Paper
Posts: 3
Registered: ‎10-22-2010
Location: San Ramon, CA
Views: 2,323
Message 4 of 7

Re: T510 WIFI connection periodically stops working even though status is connected

I was able to successfully flush cache.  When I tried to registerdns, I got the following response:

 

Registration of the DNS resource records for all adapters of this computer has been initiated.  Any errors will be reported in the Event Viewer in 15 minutes.

 

This seems to disconnect me from the access point, so I reconnect, but the intermitten "disconnection" problem still persists.  Will this Event Viewer offer any additional insights into what's going on?  

 

Thanks in advance!

 

jenobox
What's DOS?
Posts: 1
Registered: ‎12-13-2011
Location: Hungary
Views: 1,878
Message 5 of 7

Re: T510 WIFI connection periodically stops working even though status is connected

HI,

I have same problem. Did you find solution? 

Guru
Posts: 2,527
Registered: ‎03-19-2009
Location: DE
Views: 1,871
Message 6 of 7

Re: T510 WIFI connection periodically stops working even though status is connected

Please remove the mark at "Computer can disable this device to save power" in the device manager - properties of the wireless lan card, on the "Energy"-tab.

In the "Advanced"-tab you can additional set the powersave-settings (listbox)  from "maximum" to "medium" or "low". I always hat success with "medium".

--------------------------------
My home-forum: http://www.thinkpad-forum.de
Wiki: Deutsches ThinkPad-Wiki English ThinkWiki
My ThinkPad-Collection
Coffee must be like women's eyes: deep black & shiny. ThinkPads have to be like men's feet: deep black & matte!
vistaboy
Punch Card
Posts: 11
Registered: ‎05-31-2011
Location: US
Views: 1,864
Message 7 of 7

Re: T510 WIFI connection periodically stops working even though status is connected

Say, I  had seen where your having trouble on your WIFI. I had a recent problem like yours,so I found out it was not the WIFI but I was losing my browser based  outside  controls.There are steps to control that problem.

Check out current deals!


Shop current deals

Top Kudoed Authors