cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Davince
Paper Tape
Posts: 3
Registered: ‎07-10-2017
Location: GB
Views: 261
Message 1 of 2

T510 stuck in loop at startup, not even getting to splash screen / bios

Hi, I've got an old T510 that has developed a problem the last few days, now seems to be useful only as a doorstop Smiley Sad 

When you press the power button, the keyboard light flashes briefly, then the fingerprint scanner green light flashes once, there is a brief 'grunt' and all goes black, then a few seconds later it does the same thing again - it gets stuck in this loop till you pull the battery pack.

So far I've tried to see if I can just get it to start to the splash screen doing the following:

Pulling the HDD
Pulled the RAM
Resetting the CMOS
Checked all ribbon connections
Cleaned the fan.

Nothing has changed. 

Any other ideas? A couple of days before it died, it had a brief moment while running when the screen displayed a mirriad of rainbow colour lines but I have started it succesfully a few times between that happening and it failing to boot at all. 

Many thanks for any ideas!

Davince
Paper Tape
Posts: 3
Registered: ‎07-10-2017
Location: GB
Views: 207
Message 2 of 2

Re: T510 stuck in loop at startup, not even getting to splash screen / bios

If nobody has any ideas as to what the problem may be, could anyone tell me what sequence the laptop goes through to get to BIOS? I've stripped it bare now, pressing power it thinks for a few seconds then the fan wiggles a tiny bit then stops again. I've tested the fan (and left it unplugged) all fine there, but start up doesn't progress beyond that point - is the MOBO looking for anything from the fan that could be stopping it progressing, or any other component?

 

Check out current deals!


Shop current deals

Top Kudoed Authors