cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
liam3w
Paper Tape
Posts: 2
Registered: ‎05-03-2012
Location: Sweden
Views: 504
Message 1 of 3

T510i - Gobi 2000 driver not installed

Hello,

 

we have a problem with Gobi2000 miniPCI card on Thinkpad T510i, Windows 7 64 bit. It worked couple of years ok, then it just disappeared from Devices list and was not able to use any more. Some efforts for recovery has been done by investigating postings of similar issues and the abstract of the actions so far is described below

 

1. BIOS was flashed

a) 6muj28us.exe (bios update)

--> successfully updated


2. Checked that wireless radio was enabled in BIOS

--> settings ok

 

3. Uninstalled/reinstalled 

a) PowerManager

- g1ku10ww.exe (Powermanager update)

--> successfully installed

 

b) Gobi2000 Driver + BootCode

- 7xwc48ww.exe (Gobi driver)

--> Gobi2000 driver not successfully installed

--> Device Manager -> Other devices -> Qualcomm Gobi has yellow exclamation mark -> "No driver for device"

- 7xwd11ww.exe (Gobi bootcode)

--> bootcode installation not successfully installed

--> Error message "System configured for Lenovo. Unable to locate device. Download failed. Press any key to continue..."


c) Integrated Hotkey Feature

- 8jvu12ww.exe (Hotkey update)

--> successfully installed


d) AccessConnection 

- g1c742ww.exe (Access Connections update)

--> successfully installed

 

 

Does anyone has any more suggestions still to try to get Gobi2000 working again? 

 

Thanks

liam3w

 

 

 

 

Retired Support Specialist
Posts: 229
Registered: ‎05-22-2012
Location: Hong Kong
Views: 451
Message 2 of 3

Re: T510i - Gobi 2000 driver not installed

Hi liam3w,

Please try to reset BIOS, if problem remains, please kindly contact local lenovo for hardware inspection.

 

Please enter BIOS be pressing F1 in "ThinkPad Screen", F9, then F10.

Fred

T61 + X201i
liam3w
Paper Tape
Posts: 2
Registered: ‎05-03-2012
Location: Sweden
Views: 425
Message 3 of 3

Re: T510i - Gobi 2000 driver not installed

Thanks for the tips!

 

The problem was resolved and it was the hardware issue. The Gobi card was replaced with the new one and after that drivers were successfully installed and mobile broadband is working.

 

Thanks

liamw3

Check out current deals!


Shop current deals

Top Kudoed Authors