cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JasonC
Paper Tape
Posts: 3
Registered: ‎09-24-2011
Location: United States
Views: 944
Message 1 of 1

T520 - 2100: Detection error on HDD0 (Main HDD)

I found some similar threads (such as this one) but none with an actual diagnosis and resolution.

 

I have a Thinkpad T520 with a 1TB Samsung 840 EVO (an SSD like all the other reports of this problem). It has worked fine for a month then suddenly I am seeing this error on boot.

I have the latest BIOS and drive firmware updates as of the time of this writing.

 

The error appears to be "bogus" in that booting from a Linux CD, and from a Windows Recovery CD, the drive is seen just fine, with no errors reported, despite the "detection error" reported by the BIOS.

 

SMART status as reported by Linux shows the drive to be in excellent condition with no error or warning flags:

 

SMART Attributes Data Structure revision number: 1
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  5 Reallocated_Sector_Ct   0x0033   100   100   010    Pre-fail  Always       -       0
  9 Power_On_Hours          0x0032   099   099   000    Old_age   Always       -       658
 12 Power_Cycle_Count       0x0032   099   099   000    Old_age   Always       -       145
177 Wear_Leveling_Count     0x0013   099   099   000    Pre-fail  Always       -       1
179 Used_Rsvd_Blk_Cnt_Tot   0x0013   100   100   010    Pre-fail  Always       -       0
181 Program_Fail_Cnt_Total  0x0032   100   100   010    Old_age   Always       -       0
182 Erase_Fail_Count_Total  0x0032   100   100   010    Old_age   Always       -       0
183 Runtime_Bad_Block       0x0013   100   100   010    Pre-fail  Always       -       0
187 Reported_Uncorrect      0x0032   100   100   000    Old_age   Always       -       0
190 Airflow_Temperature_Cel 0x0032   062   047   000    Old_age   Always       -       38
195 Hardware_ECC_Recovered  0x001a   200   200   000    Old_age   Always       -       0
199 UDMA_CRC_Error_Count    0x003e   100   100   000    Old_age   Always       -       0
235 Unknown_Attribute       0x0012   099   099   000    Old_age   Always       -       19
241 Total_LBAs_Written      0x0032   099   099   000    Old_age   Always       -       4605059761

SMART Error Log Version: 1
No Errors Logged

 

The drive also works fine in other machines, Windows and Linux, even when it is the boot device. Other SSDs placed in this machine also show the same error now (tried a 256GB Samsung 840 EVO and a 512GB Crucial m4). It is most certainly an issue with the machine, and only seems to affect the BIOS, during boot (the fact that the OS can still see the drive means it was at minimum powered and initialized at some point).

 

Removing and reinserting the drive doesn't help.

 

Removing the DVD drive doesn't help.

 

Power cycling (even unplugging and removing the battery for a while) doesn't help.

 

I noticed that just prior to this event the computer was being extremely slow (although no IO errors were being reported) and then hung on a Windows shutdown, after which I had to force a power off (after about 15 minutes of waiting, with no drive activity). On the next boot, the problem began.

 

Now what?

 

It is clearly an issue with the BIOS, and not an uncommon problem. When will the fix be available?

Check out current deals!


Shop current deals

Top Kudoed Authors